【PAT甲级A1112】 Stucked Keyboard (20分)(c++)

1112 Stucked Keyboard (20分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB

On a broken keyboard, some of the keys are always stucked. So when you type some sentences, the characters corresponding to those keys will appear repeatedly on screen for k times.

Now given a resulting string on screen, you are supposed to list all the possible stucked keys, and the original string.

Notice that there might be some characters that are typed repeatedly. The stucked key will always repeat output for a fixed k times whenever it is pressed. For example, when k=3, from the string thiiis iiisss a teeeeeest we know that the keys i and e might be stucked, but s is not even though it appears repeatedly sometimes. The original string could be this isss a teest.

Input Specification:
Each input file contains one test case. For each case, the 1st line gives a positive integer k (1<k≤100) which is the output repeating times of a stucked key. The 2nd line contains the resulting string on screen, which consists of no more than 1000 characters from {a-z}, {0-9} and _. It is guaranteed that the string is non-empty.

Output Specification:
For each test case, print in one line the possible stucked keys, in the order of being detected. Make sure that each key is printed once only. Then in the next line print the original string. It is guaranteed that there is at least one stucked key.

Sample Input:

3
caseee1__thiiis_iiisss_a_teeeeeest

Sample Output:

ei
case1__this_isss_a_teest

题意:

键盘按键在坏掉的情况下,按下那个键,会打出k个字母,找出所给字符串中那几个键是坏掉的。并输出要本应该要打的字符串。(能打出不整除k数量的键是好的,是故意要打这么多的)。

思路:

没有每个字符,用map进行映射,若它是好的键(即输出的连续数量不被k整除)则映射为1,若是输出的连续数量能被k整除且它的映射值不为1(包括了还没有映射的情况)那么他就是坏的键。所以一开始检测出来是坏的键,之后由于连续输出了不被k整除的数量,也能把这个键重新置为好的按键。

  • 输出坏的键要按照检查的顺序,所以遍历字符串,并且再用一个map来记录这个坏的键是否已经输出过了,当判断键好坏的map值不为1,且没有输出过,那么就输出这个字符。

参考代码:

#include <iostream>
#include <string>
#include <unordered_map>

using namespace std;

int main() {
    unordered_map<char, int> mp, hashmp;
    string str, broken;
    int cnt = 1, k;
    cin >> k >> str;
    for (int i = 1; i <= str.length(); i++) {
        if (str[i] != str[i - 1]) {
            if (cnt % k != 0)mp[str[i - 1]] = 1;
            cnt = 1;
        } else {
            cnt++;
            if (cnt == k && mp[str[i - 1]] != 1) {
                mp[str[i - 1]] = 0;
            }
        }
    }
    for (int i = 0; i < str.length(); i++) {
        if (mp[str[i]] != 1 && hashmp[str[i]] != 1) {
            printf("%c", str[i]);
            hashmp[str[i]] = 1;
        }
    }
    printf("\n");
    for (int i = 0; i < str.length(); i++) {
        if (mp[str[i]] == 1) {
            printf("%c", str[i]);
            cnt = 1;
        } else {
            cnt++;
            if (cnt % k == 0)printf("%c", str[i]);
        }
    }
    return 0;
}

如有错误,欢迎指正

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值