【PAT甲级A1122】 Hamiltonian Cycle (25分)(c++)

1122 Hamiltonian Cycle (25分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:300 ms
内存限制:64 MB

The “Hamilton cycle problem” is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a “Hamiltonian cycle”.

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format Vertex1 Vertex2, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V​1​​  V​2... V​n

​​
where n is the number of vertices in the list, and V​i​​ 's are the vertices on a path.

Output Specification:
For each query, print in a line YES if the path does form a Hamiltonian cycle, or NO if not.

Sample Input:

6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1

Sample Output:

YES
NO
NO
NO
YES
NO

题意:

给出n个点和m条连通路径,判断所给路径能否经过所有的点且是个环。

思路:

经过所有的点且是个环,满足路径为n+1个点(不存在绕了一圈又多绕几个结点的情况),所以只需要判断:

  • 路径点个数为n+1;
  • 路径首尾相连;
  • 所有点都有访问过。

参考代码:

#include <iostream>
#include <vector>

using namespace std;
const int maxn=205;
int G[maxn][maxn]={0};

int main() {
    int n,m,a,b,k,num;
    scanf("%d%d",&n,&m);
    for(int i=0;i<m;i++){
        scanf("%d%d",&a,&b);
        G[a][b]=G[b][a]=1;
    }
    scanf("%d",&k);
    for(int i=0;i<k;i++){
        scanf("%d",&num);
        vector<int> v(num),vis(n,0),temp(n,1);
        bool flag=1;
        for(int j=0;j<num;j++){
            scanf("%d",&v[j]);
            vis[v[j]-1]=1;
        }
        if(num!=n+1||v[0]!=v[num-1]){
            printf("NO\n");
            continue;
        }
        for(int j=1;j<num;j++){
            if(G[v[j]][v[j-1]]!=1){
                flag=0;
                break;
            }
        }
        if(flag&&vis==temp)printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}

如有错误,欢迎指正

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值