【PAT甲级A1141】 PAT Ranking of Institutions (25分)(c++)

1141 PAT Ranking of Institutions (25分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB

After each PAT, the PAT Center will announce the ranking of institutions based on their students’ performances. Now you are asked to generate the ranklist.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​ ), which is the number of testees. Then N lines follow, each gives the information of a testee in the following format:

ID Score School
where ID is a string of 6 characters with the first one representing the test level: B stands for the basic level, A the advanced level and T the top level; Score is an integer in [0, 100]; and School is the institution code which is a string of no more than 6 English letters (case insensitive). Note: it is guaranteed that ID is unique for each testee.

Output Specification:
For each case, first print in a line the total number of institutions. Then output the ranklist of institutions in nondecreasing order of their ranks in the following format:

Rank School TWS Ns
where Rank is the rank (start from 1) of the institution; School is the institution code (all in lower case); ; TWS is the total weighted score which is defined to be the integer part of ScoreB/1.5 + ScoreA + ScoreT*1.5, where ScoreX is the total score of the testees belong to this institution on level X; and Ns is the total number of testees who belong to this institution.

The institutions are ranked according to their TWS. If there is a tie, the institutions are supposed to have the same rank, and they shall be printed in ascending order of Ns. If there is still a tie, they shall be printed in alphabetical order of their codes.

Sample Input:

10
A57908 85 Au
B57908 54 LanX
A37487 60 au
T28374 67 CMU
T32486 24 hypu
A66734 92 cmu
B76378 71 AU
A47780 45 lanx
A72809 100 pku
A03274 45 hypu

Sample Output:

5
1 cmu 192 2
1 au 192 3
3 pku 100 1
4 hypu 81 2
4 lanx 81 2

题意:
不同学校组织派出不同的人来考pat,组织按照派出的所有人成绩的总和来排名,考试有三中类型,甲级、乙级和顶级,在计算总和的时候根据考试类型加入总分中。
思路:
创建一个组织的结构体,包括总分和派出学生人数,用map来映射组织的序列号并统计组织个数。每读取一个人信息,就在映射的那个组织中添加人数和分数。将组织排序输出即可。注意的是,总分要先用double来保存再转换成int型,因为学生的成绩是取最终的整型,比如1.5+1.5取的整型是3,而不是(int)1.5+(int)1.5=2。
参考代码:

#include <iostream>
#include <string>
#include <unordered_map>
#include <algorithm>

using namespace std;
struct instutution {
    string school;
    int rank, tws, ns;
    double dtws;
} instu[100000];

bool cmp(instutution a, instutution b) {
    if (a.tws != b.tws)return a.tws > b.tws;
    else if (a.ns != b.ns)return a.ns < b.ns;
    return a.school < b.school;
}

int n, score, cnt = 0;
string id, ins;
unordered_map<string, int> mp;

int stoint(string s) {
    if (mp.find(s) != mp.end())
        return mp[s];
    mp[s] = cnt;
    instu[cnt].school = s;
    return cnt++;
}

int main() {
    scanf("%d", &n);
    for (int i = 0; i < n; i++) {
        cin >> id >> score >> ins;
        transform(ins.begin(), ins.end(), ins.begin(), ::tolower);
        int index = stoint(ins);
        instu[index].ns++;
        if (id[0] == 'A')instu[index].dtws += score;
        else if (id[0] == 'B')instu[index].dtws += score / 1.5;
        else instu[index].dtws += score * 1.5;
    }
    for (int i = 0; i < cnt; i++)instu[i].tws = instu[i].dtws;
    sort(instu, instu + cnt, cmp);
    printf("%d\n", cnt);
    for (int i = 0; i < cnt; i++) {
        instu[i].rank = i + 1;
        if (i > 0 && instu[i].tws == instu[i - 1].tws)instu[i].rank = instu[i - 1].rank;
        printf("%d %s %d %d\n", instu[i].rank, instu[i].school.c_str(), instu[i].tws, instu[i].ns);
    }
    return 0;
}

如有错误,欢迎指正

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值