【PAT甲级A1151】LCA in a Binary Tree (30分)(c++)

1151 LCA in a Binary Tree (30分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

Given any two nodes in a binary tree, you are supposed to find their LCA.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:
For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found…

Sample Input:

6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

题意:

给出一棵树的中序和先序输出,然后给出若干对点,计算这对点的最近公共根,若没找到点,这输出情况,若其中一个点就是根输出情况。

思路:

不着急构建树。给出一棵树的中序遍历,意味着所给两个点的根结点一定在中序遍历数列的两节点之间。所以我们的目的就是去找根结点,判断此根结点是否在所给两节点之间,若两点都在左/右边,那就往左/右边继续找根结点,而找根结点恰恰能通过中序和先序遍历找到(真巧)。

参考代码:

#include <cstdio>
#include <vector>
#include <unordered_map>

using namespace std;

int m, n, u, v;
unordered_map<int, int> mp;
vector<int> in, pre;

void lca(int prel, int prer, int inl, int inr) {
    int root = pre[prel], k = mp[root];
    int numleft = k - inl;
    if ((k >= mp[u] && k <= mp[v]) || (k >= mp[v] && k <= mp[u])) {
        if (k == mp[u] || k == mp[v])printf("%d is an ancestor of %d.\n", root, k == mp[u] ? v : u);
        else printf("LCA of %d and %d is %d.\n", u, v, root);
        return;
    } else if (k > mp[u] && k > mp[v])
        lca(prel + 1, prel + numleft, inl, k - 1);
    else lca(prel + numleft + 1, prer, k + 1, inr);
}

int main() {
    scanf("%d%d", &m, &n);
    in.resize(n + 1);
    pre.resize(n + 1);
    for (int i = 1; i <= n; i++) {
        scanf("%d", &in[i]);
        mp[in[i]] = i;
    }
    for (int i = 1; i <= n; i++)scanf("%d", &pre[i]);
    for (int i = 0; i < m; i++) {
        scanf("%d%d", &u, &v);
        if (!mp[u] && !mp[v])printf("ERROR: %d and %d are not found.\n", u, v);
        else if (!mp[u] || !mp[v])printf("ERROR: %d is not found.\n", mp[u] ? v : u);
        else lca(1, n, 1, n);
    }
    return 0;
}

如有错误,欢迎指正

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值