C/C++实现称硬币

      有12枚硬币,其中有11枚真币和1枚假币。假币和真币重量不同,但不知道假币比真币轻还是重。现在,用一架天平称了这些币三次,告诉你称的结果,请你找出假币并且确定假币是轻还是重。

 输入样例:

1

ABCD EFGH even  //天平左边是ABCD四枚,右边是EFGH,平衡。

ABCI EFJK up  //右边翘起来

ABIJ EFGH even  //相同

//表示的都是右边重量

 

输出样例:

k is the counterfeit coin and it is light

======================================

======================================

======================================

 

#include<bits/stdc++.h>
using namespace std;
char Left[3][7];    //左边硬币 
char Right[3][7];    //右边硬币 
char Result[3][7];    //结果 

//light为真表示假设假币为轻,否则表示假币为重 
bool IsFake(char c,bool light){
    for(int i=0;i<3;i++){
        char *pLeft,*pRight;    //天平指向两边字符串
        if(light){
            pLeft=Left[i];
            pRight=Right[i];
        } 
        else{
            pLeft=Right[i];
            pRight=Left[i];
        }
        switch(Result[i][0]){
            //天平右边的情况
            case'u':
                if(strchr(pRight,c)==NULL)
                    return false;    break;
            case'e':
                if(strchr(pLeft,c)||strchr(pRight,c))
                    return false;    break;
            case'd':
                if(strchr(pLeft,c)==NULL)
                    return false;    break; 
        }
    } 
    return true;
    

int main()
{
    int t;
    cin>>t;
    while(t--){
        for(int i=0;i<3;++i)
        cin>>Left[i]>>Right[i]>>Result[i];
        for(char c='A';c<='L';c++){
            if(IsFake(c,true)){
                cout<<c<<"is the counterfei coin and it is light.\n";
                break;
            }
            else if(IsFake(c,false)){
                cout<<c<<"is the counterfei coin and it is heavy.\n";
                break;
            }
        }
    }
    return 0;
 } 

  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值