杭电acm 5053 the Sum of Cube(简单水题)

the Sum of Cube
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2946    Accepted Submission(s): 1235


Problem Description
A range is given, the begin and the end are both integers. You should sum the cube of all the integers in the range.
 

Input
The first line of the input is T(1 <= T <= 1000), which stands for the number of test cases you need to solve.
Each case of input is a pair of integer A,B(0 < A <= B <= 10000),representing the range[A,B].
 

Output
For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then output the answer – sum the cube of all the integers in the range.
 

Sample Input

2
1 3
2 5

 

Sample Output

Case #1: 36
Case #2: 224

 

Source

2014 ACM/ICPC Asia Regional Shanghai Online

记得1*1*1+2*2*2+3*3*3+.....+n*n*n=((n* ( n+1 ) ) /2 ) * ( ( n* ( n+1 ) ) /2 )

不知道公式怎么来的,我博客有公式推导过程

代码:
#include<stdio.h>
#include<string.h>
int main()
{
   int N;
   scanf("%d",&N);
   int z=1;
   while(N--)
   {
     int i,n,m;
     scanf("%d %d",&n,&m);
     n=n-1;
     long long sum=0;
     long long sum1=(n*(n+1))/2;
     sum1=sum1*sum1;
     long long sum2=(m*(m+1))/2;
     sum2=sum2*sum2;
     sum=sum2-sum1;
     printf("Case #%d: ",z++);
     printf("%lld\n",sum);
   }
   return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值