杭电 4734F(x)(数位dp)

F(x)

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5775    Accepted Submission(s): 2184


Problem Description
For a decimal number x with n digits (A nA n-1A n-2 ... A 2A 1), we define its weight as F(x) = A n * 2 n-1 + A n-1 * 2 n-2 + ... + A 2 * 2 + A 1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).
 

Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 10 9)
 

Output
For every case,you should output "Case #t: " at first, without quotes. The  t is the case number starting from 1. Then output the answer.
 

Sample Input
  
  
3 0 100 1 10 5 100
 

Sample Output
  
  
Case #1: 1 Case #2: 2 Case #3: 13
 

Source
想法:数位dp
题目给了个f(x)的定义:F(x) = An * 2n-1 + An-1 * 2n-2 + ... + A2 * 2 + A1 * 1,Ai是十进制数位,然后给出a,b求区间[0,b]内满足f(i)==f(a)的i的个数。
常规想:这个f(x)计算就和数位计算是一样的,就是加了权值,所以dp[pos][sum],这状态是基本的。a是题目给定的,f(a)是变化的不过f(a)最大好像是4600的样子。如果要memset优化就要加一维存f(a)的不同取值,那就是dp[10][4600][4600],这显然不合法。
这个时候就要用减法了,dp[pos][sum],sum不是存当前枚举的数的前缀和(加权的),而是枚举到当前pos位,后面还需要凑sum的权值和的个数,
也就是说初始的是时候sum是f(a),枚举一位就减去这一位在计算f(i)的权值,显然sum=0时就是满足的,后面的位数凑足sum位就可以了。
仔细想想这个状态是与f(a)无关的(新手似乎很难理解),一个状态只有在sum=0时才满足,如果我们按常规的思想求f(i)的话,那么最后sum=f(a)才是满足的条件。
代码:
#include<stdio.h>
#include<string.h>
int xx;
int dp[12][10010];
int a[12];
int f(int n)
{
    if(n==0)
        return 0;
    int ans=f(n/10);
    return ans*2+(n%10);
}
int dfs(int pos,int sum,int limit)
{
    if(pos<0)
        return sum<=xx;
    if(sum>xx)
        return 0;
    if(!limit && dp[pos][xx-sum] != -1)
        return dp[pos][xx-sum];
    int up = limit ? a[pos] : 9;
    int tmp = 0;
    for(int i = 0; i <= up; i++)
    {
       tmp += dfs(pos-1,sum+i*(1<<pos),limit&&(i==a[pos]));
    }
    if(!limit)
        dp[pos][xx-sum] = tmp;
    return tmp;


}
int solver(int m)
{
    int pos=0;
    while(m)
    {
        a[pos++]=m%10;
        m/=10;
    }
    dfs(pos-1,0,1);


}
int main()
{
    int T;
    scanf("%d",&T);
    int ws=1;
    memset(dp,-1,sizeof(dp));
    while(T--)
    {


     int n,m;
     scanf("%d%d",&n,&m);
     xx=f(n);
     printf("Case #%d: %d\n",ws++,solver(m));
    }
    return 0;
}
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值