HDU-4734-F(x)(数位DP)

F(x)

Problem Description

For a decimal number x with n digits (AnAn-1An-2 … A2A1), we define its weight as F(x) = An * 2n-1 + An-1 * 2n-2 + … + A2 * 2 + A1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).

Input

The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 109)

Output

For every case,you should output "Case #t: " at first, without quotes. The t is the case number starting from 1. Then output the answer.

Sample Input

3
0 100
1 10
5 100
 

Sample Output

Case #1: 1
Case #2: 2
Case #3: 13

解题思路:

数位DP。
在枚举pos位的时候,dp[pos][sum] sum保存的不是前缀和,而是f(a)-sum的状态。在枚举到最后一位的时候,sta<=fa就是合法的。在枚举之前的位的时候就可以直接返回sum-sta的状态。这样就不用记忆前缀和的状态。
也就是说,如果保存的是前缀和的状态,那么在枚举的时候,就既要保存前缀的状态,又要记录后续的状态。这样就会出现4600*4600的爆炸数组。
保存sum-sta的状态。这样就可以用一个遍历记录前缀和的状态,然后用这个数组记录后缀的状态,优化空间。
参考博客:
https://blog.csdn.net/wust_zzwh/article/details/52100392

AC代码:

#include <bits/stdc++.h>
#define int long long
using namespace std;

const int N = 1e4+10;
int num[20];
int sum;
int dp[20][N];
int dfs(int pos,int sta,int limit)
{
    if(pos == -1) return sta <= sum;
    if(sta > sum) return 0;
    if(!limit && dp[pos][sum-sta] != -1) return dp[pos][sum-sta];
    int tmp = 0;
    int up = limit ? num[pos] : 9;
    for(int i = 0; i <= up; i ++)
        tmp += dfs(pos-1,sta+i*(1<<pos),limit && num[pos] == i);
    if(!limit) dp[pos][sum-sta] = tmp;
    return tmp;
}

int res(int x)
{
    int pos = 0;
    while(x)
    {
        num[pos++] = x%10;
        x /= 10;
    }
    return dfs(pos-1,0,1);
}

int f(int x)
{
    return x == 0 ? 0 : f(x/10)*2+(x%10);
}

signed main()
{
    int t;
    int cas = 1;
    scanf("%lld",&t);
    memset(dp,-1,sizeof(dp));
    while(t--)
    {
        int x,n;
        scanf("%lld%lld",&x,&n);
        sum = f(x);
        printf("Case #%lld: %lld\n",cas++,res(n));
    }
    return 0;
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值