FZU 2264 Card Game (First Edition)(数学概率题)

 Problem 2264 Card Game (First Edition)

Accept: 114    Submit: 343
Time Limit: 1000 mSec    Memory Limit : 32768 KB

 Problem Description

Fat brother and Maze are playing a kind of special (hentai) game with some cards. There are N*2 cards in this game for the players to use, this is the card deck. The game goes for N rounds and in each round, Fat Brother would draw one card from the remaining card deck randomly and then Maze would draw one card from the remaining card deck randomly. Then they compare for the integers which is written on these two cards. The player with the higher number wins this round and score 1 victory point. And then these two cards are removed from the game such that they would not appear in the later rounds. As we all know, Fat Brother is very clever, so he would like to know the expect number of the victory points he could get if he knows all the integers written in these cards.

Note that the integers written on these N*2 cards are pair wise distinct. At the beginning of this game, each player has 0 victory point.

 Input

The first line of the data is an integer T (1 <= T <= 100), which is the number of the text cases.

Then T cases follow, each case contains an integer N (1 <= N<=10000) which described before. Then follow one line with N*2 integers, which indicate the integers in these cards.

All the integers are positive and no morethan 10000000.

 Output

For each case, output the case number first, and then output the expect number of the victory points Fat Brother could get in this game. The answer should be rounded to 2 digits after the decimal point.

 Sample Input

211 221 2 3 4

 Sample Output

Case 1: 0.50Case 2: 1.00

 Source

第七届福建省大学生程序设计竞赛-重现赛(感谢承办方闽江学院)
想法:题意求眫子获胜概率,每场有三种结果:胜输平
取掉平局的情况:去重
概率=去重/2*(1/2)
代码:
#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
using namespace std;
int a[20010];
int main()
{
  int T;
  scanf("%d",&T);
  int ws=1;
  while(T--)
  {
      memset(a,0,sizeof(a));
      int n;
      scanf("%d",&n);
      int i,j;
      for(i=0;i<2*n;i++)
      {
         scanf("%d",&a[i]);
      }
      /*sort(a,a+2*n);
       for(i=0;i<2*n;i++)
      {
         printf("%d\t",a[i]);
      }*/
      int count=1;
      for(i=1;i<2*n;i++)
      {
          if(a[i]==a[i-1])
            continue;
          else
            count++;
      }
      printf("Case %d: ",ws++);
      printf("%.2lf\n",count*1.0/4);
  }
  return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值