【期望】fuzoj 2265 Card Game (Second Edition)

Accept: 73    Submit: 220
Time Limit: 1000 mSec    Memory Limit : 32768 KB

 Problem Description

Fat brother and Maze are playing a kind of special (hentai) game with some cards. In this game, every player gets N cards at first and these are their own card deck. The game goes for N rounds and in each round, Fat Brother and Maze would draw one card from their own remaining card deck randomly and compare for the integer which is written on the cards. The player with the higher number wins this round and score 1 victory point. And then these two cards are removed from the game such that they would not appear in the later rounds. As we all know, Fat Brother is very clever, so he would like to know the expect number of the victory points he could get if he knows all the integers written in these cards.

Note that the integers written on these N*2 cards are pair wise distinct. At the beginning of this game, each player has 0 victory point.

 Input

The first line of the data is an integer T (1 <= T <= 100), which is the number of the text cases.

Then T cases follow, each case contains an integer N (1 <=N<=10000) which described before. Then follow two lines with N integers each. The first N integers indicate Fat Brother’s cards and the second N integers indicate Maze’s cards.

All the integers are positive and no more than 10000000.

 Output

For each case, output the case number first, and then output the expect number of victory points Fat Brother would gets in this game. The answer should be rounded to 2 digits after the decimal point.

 Sample Input

2
1
1
2
2
1 3
2 4

 Sample Output

Case 1: 0.00
Case 2: 0.50

 Source

第七届福建省大学生程序设计竞赛-重现赛(感谢承办方闽江学院)


题意:fat brother 与 maze玩游戏,每个人手上有n张牌,每一轮每人亮出一张牌来比大小,谁大谁就可以得一分,刚开始每人都有0分,而且这2n张牌各不相同;问fat brother在知道双方的牌的情况下,fat brother得分的期望。

思路:我们不要直接考虑游戏最后得分的期望,而是而是转化为每一轮游戏得分的期望和! 游戏总共有n轮,每一轮的结果是:fat要么得1分要么不得分(服从两点分布),所以每一轮得分的期望就是1*(k/n);(k是maze的牌值 小于fat第i张牌值 的数量)。

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int a[10010],b[10010];
int main()
{
    int t,round=0;
    scanf("%d",&t);
    while(t--)
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));

        int n;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        for(int i=0;i<n;i++)
            scanf("%d",&b[i]);

        sort(a,a+n);
        sort(b,b+n);

        double sum=0;
        for(int i=0;i<n;i++)
        {
            int k=upper_bound(b,b+n,a[i])-b;
            sum+=k;
//            printf("%d\n",k);
        }
        printf("Case %d: ",++round);
        printf("%.2f\n",sum/n);
    }
    return 0;
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值