CSU 1809: Parenthesis

Description

Bobo has a balanced parenthesis sequence P=p 1 p 2…p n of length n and q questions.
The i-th question is whether P remains balanced after p ai and p bi  swapped. Note that questions are individual so that they have no affect on others.
Parenthesis sequence S is balanced if and only if:
1. S is empty;
2. or there exists  balanced parenthesis sequence A,B such that S=AB;
3. or there exists  balanced parenthesis sequence S' such that S=(S').

Input

The input contains at most 30 sets. For each set:
The first line contains two integers n,q (2≤n≤10 5,1≤q≤10 5).
The second line contains n characters p 1 p 2…p n.
The i-th of the last q lines contains 2 integers a i,b i (1≤a i,b i≤n,a i≠b i).

Output

For each question, output " Yes" if P remains balanced, or " No" otherwise.

Sample Input

4 2
(())
1 3
2 3
2 1
()
1 2

Sample Output

No
Yes
No

Hint

Source

湖南省第十二届大学生计算机程序设计竞赛
代码:
#include<stdio.h>
#include<string.h>
int main()
{
    int n,m;
    char str[100010];
    int s[100010];
    int s1[100010];
    while(scanf("%d%d",&n,&m)!=EOF)
    {
       int i,j;
      scanf("%s",str);
      int len=strlen(str);
      s[0]=0;
      s1[0]=0;
      for(i=0;i<len;i++)
      {
       if(str[i]=='(')
        {
             s[i+1]=1;
             s1[i+1]=s1[i]+1;
        }
        if(str[i]==')')
        {
           s[i+1]=-1;
           s1[i+1]=s1[i]-1;
        }
      }
      int a,b,t;
      for(i=0;i<m;i++)
      {
          int sum=0;
          int flag=0;
          scanf("%d %d",&a,&b);
          if(a>b)
          {
             t=a;a=b;b=t;
          }
          if(s[a]==s[b]||(s[a]==-1&&s[b]==1))
          {
              printf("Yes\n");
              continue;
          }
          sum+=s1[a-1];
          for(j=a;j<=b;j++)
          {
              if(sum<0)
              {
                  flag=1;
                  break;
              }
              if(j==a||j==b)
              {
                 if(j==a)
                    sum+=s[b];
                else
                    sum+=s[a];
              }
             else  sum+=s[j];
          }
          sum+=s[len]-s[b];
           if(sum<0)
            {
                  flag=1;
            }
          if(flag) printf("No\n");
          else
          {
              printf("Yes\n");
          }
      }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值