HDU 6185Covering(矩阵快速幂)

Covering

Time Limit : 5000/2500ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 2   Accepted Submission(s) : 2
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

Bob's school has a big playground, boys and girls always play games here after school.

To protect boys and girls from getting hurt when playing happily on the playground, rich boy Bob decided to cover the playground using his carpets.

Meanwhile, Bob is a mean boy, so he acquired that his carpets can not overlap one cell twice or more.

He has infinite carpets with sizes of  1×2  and  2×1 , and the size of the playground is  4×n .

Can you tell Bob the total number of schemes where the carpets can cover the playground completely without overlapping?

Input

There are no more than 5000 test cases. 

Each test case only contains one positive integer n in a line.

1n1018

Output

For each test cases, output the answer mod 1000000007 in a line.

Sample Input

1
2

Sample Output

1
5

Source

2017ACM/ICPC广西邀请赛-重现赛(感谢广西大学)
想法:
  1. 推导公式:F[i]   = F[i-1] + 5*F[i-2] + F[i-3] - F[i-4] 
代码;
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn = 4;
const ll mod= 1e9+7;
struct Matrix
{
    ll tmp[maxn][maxn];
}a;
void init()
{
    for(int i=0;i<maxn;i++)
    {
        for(int j=0;j<maxn;j++)
        {
            a.tmp[i][j]=0;
        }
    }
    a.tmp[0][0]=a.tmp[0][2]=1;
    a.tmp[0][1]=5;
    a.tmp[0][3]=-1;
    a.tmp[1][0]=a.tmp[2][1]=a.tmp[3][2]=1;
    return;
}
Matrix mul(Matrix a,Matrix b)
{
    Matrix ans;
    for(int i=0;i<maxn;i++)
        for(int j=0;j<maxn;j++)
        {
            ans.tmp[i][j]=0;
            for(int k=0;k<maxn;k++)
            {
                ans.tmp[i][j]+=(a.tmp[i][k]*b.tmp[k][j]+mod)%mod;
                ans.tmp[i][j]%=mod;
            }
        }
    return ans;
}
void fun(Matrix ans,ll k)
{
    for(int i=0;i<maxn;i++)
    {
        for(int j=0;j<maxn;j++)
        {
            a.tmp[i][j]=(i==j);
        }
    }
    while(k)
    {
        if(k%2)  a=mul(a,ans);
        ans=mul(ans,ans);
        k/=2;
    }
    return ;
}
int main()
{
    Matrix t;
    ll n;
    for(int i=0;i<maxn;i++)
    {
        for(int j=0;j<maxn;j++)
        {
            t.tmp[i][j]=0;
        }
    }
    t.tmp[0][0]=36;
    t.tmp[1][0]=11;
    t.tmp[2][0]=5;
    t.tmp[3][0]=1;
    while(~scanf("%lld",&n))
    {
        init();
        if(n<=4)
        {
            printf("%lld\n",t.tmp[4-n][0]);
            continue;
        }
        fun(a,n-4);
        a=mul(a,t);
        printf("%lld\n",a.tmp[0][0]%mod);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值