Sumsets

Sumsets

Description Farmer John commanded his cows to search for different
sets of numbers that sum to a given number. The cows use only numbers
that are an integer power of 2. Here are the possible sets of numbers
that sum to 7:
1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <=
N <= 1,000,000). Input A single line with a single integer, N. Output
The number of ways to represent N as the indicated sum. Due to the
potential huge size of this number, print only last 9 digits (in base

Sample Input
7
Sample Output
6

/*这题主要用到了递归。
因为只能用2的幂来划分n,所以如果输入的数n是奇数,则一定会有1,把n减去1后,它的化分数与n-1一样。
如果n是偶数,分两种情况讨论:
1.没有1,则此时n的化分数与n/2一样;
2.2个1,此时n的化分数与n-2一样。*/

#include <iostream>
using namespace std;
long s[1000001];
int main() {
    int n;
    s[1] = 1;
    s[2] = 2;
    for (n = 3; n < 1000001; n++) {
        if (n % 2 == 1) s[n] = s[n - 1];
        else s[n] =( s[n - 2] + s[n / 2])%1000000000;
    }
    while (cin >> n) {
        cout << s[n] << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值