Codeup墓地 Contest100000577 问题 B:Hello World for U

题目描述

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, “helloworld” can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

输入

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

输出

For each test case, print the input string in the shape of U as specified in the description.

样例输入

helloworld!

样例输出

h   !
e   d
l   l
lowor

代码

#include<cstdio>
#include<cstring>
int main(){
	char str[81];
	scanf("%s",str);
	int len=strlen(str);
	int side=(len+2)/3;
	int mid=len-side*2;
	for(int i=0;i<side;++i){
		if(i!=side-1){
			for(int j=0;j<mid+2;++j){
				if(j==0){
					printf("%c",str[i]);
				}else if(j==mid+1){
					printf("%c\n",str[len-i-1]);
				}else{
					printf(" ");
				}
			}
		}
		else{
			for(int j=i;j<len-i;++j){
				printf("%c",str[j]);
			}
		}
	}
	return 0; 
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值