1034 Head of a Gang (30分)

One way that the police finds the head of a gang is to check people’s phone calls. If there is a phone call between AAA and BBB, we say that AAA and BBB is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A “Gang” is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threshold KKK. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers NNN and KKK (both less than or equal to 1000), the number of phone calls and the weight threthold, respectively. Then NNN lines follow, each in the following format:

Name1 Name2 Time

where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.

Output Specification:

For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

Sample Input 1:

8 59
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 1:

2
AAA 3
GGG 3

Sample Input 2:

8 70
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 2:

0

解法一:DFS

  1. 使用 map<string, vector<int> 存储图,使用 vector 存储邻接表(注意是无向图);
  2. 题中需要知道每个人的权值, 即与之相关的通话时长之和,可在输入的时候累加即可;
  3. 遍历图,求每个连通图中的结点个数,结点上边权之和,头目(点权最大的结点)。

注意: dfs遍历时,首先求和边权,为了不重复计算,需要边权置 0;

参考代码
#include <bits/stdc++.h>
using namespace std;
#define it insert
#define pob pop_back
#define pub push_back
#define emb emplace_back
#define all(v) (v).begin(), (v).end()
#define mkp(a, b) make_pair(a, b)
#define forr(n, s, e) for (int(n) = (s); (n) < (e); (n)++)
#define rfor(n, s, e) for (int(n) = (s); (n) > (e); (n)--)
using LL = long long;
using VI = vector<int>;
using VVI = vector<vector<int>>;
using PII = pair<int, int>;
using PIL = pair<int, LL>;
using PLL = pair<LL, LL>;
const int MOD = 1e9 + 7;
const int INF = 1e9 + 7;
const int MAXN = 1e5 + 7;

map<string, vector<string>> graph;
map<pair<string, string>, int> edges;
map<string, int> weight;
unordered_set<string> visited;
void dfs(string f, int &sum, string &head, int &cnt) {
    cnt++;
    visited.it(f);
    if (weight[f] > weight[head]) head = f;
    for (auto &t : graph[f]) {
        sum += edges[mkp(f, t)];
        edges[mkp(f, t)] = 0;
        edges[mkp(t, f)] = 0;
        if (visited.find(t) == visited.end()) {
            dfs(t, sum, head, cnt);
        }
    }
}
int main() {
    int n, k;
    scanf("%d %d", &n, &k);
    string n1, n2;
    int w;
    forr(i, 0, n) {
        cin >> n1 >> n2 >> w;
        graph[n1].push_back(n2); //邻接表存储图
        graph[n2].push_back(n1);
        edges[mkp(n1, n2)] += w; //边权
        edges[mkp(n2, n1)] += w;
        weight[n1] += w; //点权
        weight[n2] += w;
    }
    map<string, int> ans;
    // dfs所有连通分量
    for (auto &x : weight) {
        if (visited.find(x.first) == visited.end()) {
            int sum = 0, cnt = 0;
            string head = x.first;
            dfs(x.first, sum, head, cnt);
            if (sum > k && cnt > 2) ans[head] = cnt;
        }
    }
    printf("%ld\n", ans.size());
    for (auto &x : ans) {
        printf("%s %d\n", x.first.c_str(), x.second);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值