1003 The Dominator of Strings

Problem Description

Here you have a set of strings. A dominator is a string of the set
dominating all strings else. The string S is dominated by T if S is a
substring of T.

Input

The input contains several test cases and the first line provides the
total number of cases. For each test case, the first line contains an
integer N indicating the size of the set. Each of the following N
lines describes a string of the set in lowercase. The total length of
strings in each case has the limit of 100000. The limit is 30MB for
the input file.

Output

For each test case, output a dominator if exist, or No if not.

Sample Input

3
10
you
better
worse
richer
poorer
sickness
health
death
faithfulness
youbemyweddedwifebetterworsericherpoorersicknesshealthtilldeathdouspartandpledgeyoumyfaithfulness
5
abc
cde
abcde
abcde
bcde
3
aaaaa
aaaab
aaaac

Sample Output

youbemyweddedwifebetterworsericherpoorersicknesshealthtilldeathdouspartandpledgeyoumyfaithfulness
abcde
No

我的代码超时!!至今不知道为什么……
现在知道了>-<,加上这句就好了cin.sync_with_stdio(false);
或者ios::sync_with_stdio(false);
当然这题还可以用ac自动机,KMP算法(我都不会| |)

#include<iostream>
#include<string.h>
using namespace std;
string str[100001];
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n,mx=0,flag=1;
        cin>>n;
        for(int i=0;i<n;i++)
        {
            cin>>str[i];
            if(strlen(str[mx].c_str())<strlen(str[i].c_str()))
                mx=i;
        }
        for(int i=0;i<n;i++)
        {
            if(str[mx].find(str[i])==string::npos)
            {
                cout<<"No"<<endl;
                flag=0;
                break;
            }
        }
        if(flag)
            cout<<str[mx]<<endl;
    }
    return 0;
}

修改后:

#include<iostream>
#include<string.h>
using namespace std;
string str[100001];
int main()
{
    cin.sync_with_stdio(false);//修改处
    int t;
    cin>>t;
    while(t--)
    {
        int n,mx=0,flag=1;
        cin>>n;
        for(int i=0;i<n;i++)
        {
            cin>>str[i];
            if(strlen(str[mx].c_str())<strlen(str[i].c_str()))
                mx=i;
        }
        for(int i=0;i<n;i++)
        {
            if(str[mx].find(str[i])==string::npos)
            {
                cout<<"No"<<endl;
                flag=0;
                break;
            }
        }
        if(flag)
            cout<<str[mx]<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值