(大数+sc.hasNext()处理多次读入问题)N!

Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N! 
InputOne N in one line, process to the end of file. 
OutputFor each N, output N! in one line. 
Sample Input
1
2
3
Sample Output
1
2
6  

解题:hasNext()处理字符读入问题,和Next()效果其实是一样的,系统都会等待输入下一个字符,只是返回值不同,hasNext()会返回true,next()返回输入的字符。

import java.math.BigInteger;
import java.util.Scanner;

public class Main {
	public static void main(String[] args){
		Scanner sc=new Scanner(System.in);
		int n;
		while(sc.hasNext()){
			n=sc.nextInt();
			BigInteger res=BigInteger.ONE;
			for(int i=1;i<=n;i++)
				res=res.multiply(BigInteger.valueOf(i));
			System.out.println(res);
		}
	}

}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值