hdu-4990 Reading comprehension(快速幂+矩阵)

Read the program below carefully then answer the question. 
#pragma comment(linker, "/STACK:1024000000,1024000000") 
#include <cstdio> 
#include<iostream> 
#include <cstring> 
#include <cmath> 
#include <algorithm> 
#include<vector> 

const int MAX=100000*2; 
const int INF=1e9; 

int main() 

  int n,m,ans,i; 
  while(scanf("%d%d",&n,&m)!=EOF) 
  { 
    ans=0; 
    for(i=1;i<=n;i++) 
    { 
      if(i&1)ans=(ans*2+1)%m; 
      else ans=ans*2%m; 
    } 
    printf("%d\n",ans); 
  } 
  return 0; 
}
Input
Multi test cases,each line will contain two integers n and m. Process to end of file. 
[Technical Specification] 
1<=n, m <= 1000000000
Output
For each case,output an integer,represents the output of above program.
Sample Input
1 10
3 100
Sample Output
1
5

题意:

按照题目的代码运行肯定会超时,而且数据会爆int,所以我用了快速幂矩阵。 通项公式为f[n] = f[n -1] + 2 * f[n -2] + 1;

ps:写矩阵相乘函数的时候自己脑抽竟然写反了两个参数。

#include<iostream>
#include<cstdio>
#define ll long long
using namespace std;

struct node{
	ll m[3][3];
};

int n,m;
node mult(node a, node b){
	node te;
	for(int i = 0; i < 3; i++)
		for(int j = 0; j < 3; j++){
			te.m[i][j] = 0;
			for(int k = 0; k < 3; k++){
				te.m[i][j] += a.m[i][k] * b.m[k][j];
				te.m[i][j] %= m; 
			} 
		}
	return te;
}

ll powermod(){
	node base={0, 2, 0, 1, 1, 0, 0, 1, 1}, ans={0, 1, 1, 0, 0, 0, 0, 0, 0};
	while(n){
		if(n&1) ans = mult(ans, base);
		n = n / 2;
		base =	mult(base, base);		
	}	
	return ans.m[0][0];
}
int main(){
	while(scanf("%d%d", &n,&m) != EOF){
		
		printf("%I64d\n",powermod());
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Blaze Jack

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值