hdu4882 ZCC Loves Codefires(贪心)

Though ZCC has many Fans, ZCC himself is a crazy Fan of a coder, called "Memset137".
 It was on Codefires(CF), an online competitive programming site, that ZCC knew Memset137, and immediately became his fan. 
But why? 
 Because Memset137 can solve all problem in rounds, without unsuccessful submissions; his estimation of time to solve certain problem is so accurate, that he can surely get an Accepted the second he has predicted. He soon became IGM, the best title of Codefires. Besides, he is famous for his coding speed and the achievement in the field of Data Structures. 
 After become IGM, Memset137 has a new goal: He wants his score in CF rounds to be as large as possible. 
 What is score? In Codefires, every problem has 2 attributes, let's call them Ki and Bi(Ki, Bi>0). if Memset137 solves the problem at Ti-th second, he gained Bi-Ki*Ti score. It's guaranteed Bi-Ki*Ti is always positive during the round time. 
 Now that Memset137 can solve every problem, in this problem, Bi is of no concern. Please write a program to calculate the minimal score he will lose.(that is, the sum of Ki*Ti). 
InputThe first line contains an integer N(1≤N≤10^5), the number of problem in the round. 
 The second line contains N integers Ei(1≤Ei≤10^4), the time(second) to solve the i-th problem. 
 The last line contains N integers Ki(1≤Ki≤10^4), as was described.OutputOne integer L, the minimal score he will lose.Sample Input
3
10 10 20
1 2 3
Sample Output
150


        
  
Hint
Memset137 takes the first 10 seconds to solve problem B, then solves problem C at the end of the 30th second. Memset137 gets AK at the end of the 40th second.
L = 10 * 2 + (10+20) * 3 + (10+20+10) * 1 = 150. 
        
 

很有趣的题目,推导一下公式就会发现只要相邻的两个题目a.t*b.k < b.t*a.k就可以使得最小。 用了sort。

 

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
#define ll long long
using namespace std;
const int mx = 1e5+10; 
int n;
struct tk{
	int t,k;
}no[mx];

bool cmp(tk a, tk b){
	return a.t*b.k < b.t*a.k; 
}

int main(){
  while(scanf("%d", &n) != EOF){
  	for(int i = 0; i < n; i++)
  	   scanf("%d", &no[i].t);
  	for(int i = 0; i < n; i++)
  	   scanf("%d", &no[i].k);
  	sort(no,no+n,cmp);
  
  	ll t = no[0].t;
  	ll sum = t * no[0].k;
  	for(int i = 1; i<n; i++){
  		t += no[i].t;
		sum += no[i].k * t;
	  }
	  
	cout<<sum<<endl;
  }	


return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Blaze Jack

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值