ZCC Loves Codefires 比例贪心 Codeforces

    算法训练至贪心法专题,介绍一题使用贪心法求解,求解方法为比例贪心。

    见题目:

Description

Though ZCC has many Fans, ZCC himself is a crazy Fan of a coder, called "Memset137". 
It was on Codefires(CF), an online competitive programming site, that ZCC knew Memset137, and immediately became his fan. 
But why? 
Because Memset137 can solve all problem in rounds, without unsuccessful submissions; his estimation of time to solve certain problem is so accurate, that he can surely get an Accepted the second he has predicted. He soon became IGM, the best title of Codefires. Besides, he is famous for his coding speed and the achievement in the field of Data Structures. 
After become IGM, Memset137 has a new goal: He wants his score in CF rounds to be as large as possible. 
What is score? In Codefires, every problem has 2 attributes, let's call them Ki and Bi(Ki, Bi>0). if Memset137 solves the problem at Ti-th second, he gained Bi-Ki*Ti score. It's guaranteed Bi-Ki*Ti is always positive during the round time. 
Now that Memset137 can solve every problem, in this problem, Bi is of no concern. Please write a program to calculate the minimal score he will lose.(that is, the sum of Ki*Ti). 
 

Input

The first line contains an integer N(1≤N≤10^5), the number of problem in the round. 
The second line contains N integers Ei(1≤Ei≤10^4), the time(second) to solve the i-th problem. 
The last line contains N integers Ki(1≤Ki≤10^4), as was described.
 

Output

One integer L, the minimal score he will lose.
 

Sample Input

    
    
3 10 10 20 1 2 3
 

Sample Output

    
    
150

Hint

Memset137 takes the first 10 seconds to solve problem B, then solves problem C at the end of the 30th second. Memset137 gets AK at the end of the 40th second. L = 10 * 2 + (10+20) * 3 + (10+20+10) * 1 = 150. 
    初始看这一题对于新手来说可能不太有思路,但如果将整个的安排顺序抽象成任何两个活动之间的安排先后,再将任意两个抽象成所有活动的排序,其实也就是按照一定的排序规则进行排序得到结果而已。这种思考方式需要记住,要学会转化。

    题意分析:题目给出每一题需要完成的时间和题目每一单位时间的罚时,后续题目的罚时建立在当前所用掉的所有时间的基础上。抽象出任意两个活动a、b,若将a活动先执行,则罚时A:k1*t1+k2*(t1+t2),若b先执行,则罚时B:k1(t1+t2)+k2*t2,A-B得:k2*t1-k1*t2,令其小于零即在这种情况下a先执行罚时少,化简可得结果:t1/k1<t2/k2,至此可得到判断优先级的条件,使用sort函数的自定义cmp函数即可。此条件相当于一般排序时的大于号。

    从该题可以学到抽象出任意两个对象的优先级即为整个序列的优先级。

    给出AC代码:

//该题可以转化为 任意a和b包含两个属性 x y
// A: y1.x1+y2*(x1+x2) B:y1*(x1+x2)+y2*x2  另A<B则时间较小   解得 x1/y1 <x2/y2
//所以按照此顺序排序   贪心即可
#include<stdio.h>
#include<algorithm>
using namespace std;
const int maxn=100001;
struct kt
{
	int y,x;
} a[maxn];
int cmp(kt a,kt b)
{
	return (a.x*1.0/a.y)<(b.x*1.0/b.y);
}
int main()
{
	int n;
	scanf("%d",&n);
	for(int i=0; i<n; i++)
		scanf("%d",&a[i].x);
	for(int i=0; i<n; i++)
		scanf("%d",&a[i].y);
	sort(a,a+n,cmp);
	long long  res=0,cost=0;
	for(int i=0; i<n; i++)
	{
		cost+=a[i].x;
		res+=a[i].y*cost;
	}
	printf("%I64d\n",res);
}

    做完此题也算长了见识,能力急需提高。

    特记下,以备后日回顾。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值