2018-ACM-ICPC-亚洲区域赛-北京站-A

4 篇文章 0 订阅
1 篇文章 0 订阅

!


在这里插入图片描述

Jin Yong’s Wukong Ranking List

时间限制:1000ms

单点时限:1000ms

内存限制:512MB

描述

Jin Yong was the most famous and popular Chinese wuxia (The one who fight bad people by his Wukong i.e. Wushu and Kongfu) novelist who lived in Hong Kong. Between 1955 and 1972, he wrote 14 novels which earned him a reputation as one of the greatest and most popular Chinese writers. Over 100 million copies of his works have been sold worldwide,not including a countless number of pirated copies. Jin Yong’s works seem to have magic. Once you begin to read a novel of his, you just can’t stop until you finish it.

Last month, Jin Yong passed away at the age of 94. Many Jin Yong’s fans in PKU held a meeting to memorize him. Jin Yong’s fans always like to discuss or argue or even quarrel about whose Wukong are better among the wuxia characters of his novel. During the meeting, this happened again:

Every fans said some words like “Qiao Feng’s Wukong is better than Guo Jing’s”. Obviously, those words may contradict each other and then cause quarrels. As a boring and girlfriendless male programmer of EECS school, you always want to make some things. So you are eager to point out the contradictions as soon as possible. That means, you want to find out the first one whose words contradict the words said by others before him.

Please note that if A is better than B, and B is better than C, then of course A must be better than C.

输入

There are no more than 15 test cases.

For each test case:

The first line is an integer n( 1 <= n <=20), meaning that there are n sentences.

The following n lines are those n sentences which is in the format below:

s1 s2

This means someone said that s1’s Wukong was better than s2’s. Both s1 and s2 are names of Jin Yong’s characters which consists of only English letters. It’s guaranteed that s1 and s2 are different, and their length is no more than 30. Names are case sensitive.

输出

For each test case, print the first sentence which cause a contradiction. If there are no contradiction, print 0 instead.

提示

DON’T try to figure out who are those names in the sample and waste your time.

样例输入

2
BrokenReputation ExtinctNun
HelloLaught EnvelopeNotFlat
6
LandOverWind LonelyLight
FireMonk CutTheForest
CutTheForest LookCrazy
MakeFoxRush LetMeGo
HeroAunt UniqueLand
LookCrazy FireMonk

样例输出

0
LookCrazy FireMonk

题意

​ 给你人名 代表前者比后者强 求第一个出现错误的地方 人物强弱满足传递性,A > B,B > C,A > C

题解

​ 签到题,直接 map 映射一下hash 你会发现永远是小的数字比大的数字厉害,所以,当出现大的数字比小的数字厉害的时候就是第一个错误点,太水了,我还在想什么拓扑排序啥的,懵了半天,哈哈

AC代码

#include<bits/stdc++.h>
using namespace std;
map<string,int>m1;
int main()
{
    int n;
    while(cin>>n)
    {
        m1.clear();
        int tot = 1;
        int flag = 0;
        string ans1 ,ans2;
        for(int i=0;i<n;i++)
        {
            string s1,s2;
            cin>>s1>>s2;
            if(!m1[s1]) m1[s1] = tot++;
            if(!m1[s2]) m1[s2] = tot++;
            if(m1[s1]>=m1[s2]&&flag==0)
            {
                flag = 1;
                ans1 = s1;
                ans2 = s2;
            }
        }
        if(!flag) cout<<0<<endl;
        else cout<<ans1<<" "<<ans2<<endl;
    }
}#include<bits/stdc++.h>
using namespace std;
map<string,int>m1;
int main()
{
    int n;
    while(cin>>n)
    {
        m1.clear();
        int tot = 1;
        int flag = 0;
        string ans1 ,ans2;
        for(int i=0;i<n;i++)
        {
            string s1,s2;
            cin>>s1>>s2;
            if(!m1[s1]) m1[s1] = tot++;
            if(!m1[s2]) m1[s2] = tot++;
            if(m1[s1]>=m1[s2]&&flag==0)
            {
                flag = 1;
                ans1 = s1;
                ans2 = s2;
            }
        }
        if(!flag) cout<<0<<endl;
        else cout<<ans1<<" "<<ans2<<endl;
    }
}

ps :

​ 这个真的得说在现场系列了,当时把题看完队友老哥直接上去就AC了。过两天有时间的写个退役总结

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值