PAT甲级 1044 Shopping in Mars(二分查找)

1044 Shopping in Mars (25 分)

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10​5​​), the total number of diamonds on the chain, and M (≤10​8​​), the amount that the customer has to pay. Then the next line contains N positive numbers D​1​​⋯D​N​​ (D​i​​≤10​3​​ for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of i ≤ j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + ... + Dj >M with (Di + ... + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

//题目大意:给你n个数,让你找出和为m的子串,若有多个这样的子串,按子串起始点i从小到大依次输出 ,若没有该子串,则找出和大于且最接近m的子串,若有多个满足条件的子串,则按上述规则输出;

//思路:sum[i]表示从第一个数到第i个数的和,由于sum[i]是递增的,所以可以用二分查找找到>=m的子串;

//原因:没思路;

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<vector>
using namespace std;
struct Node
{
    int x,y;
};
vector<Node>ans;
int main()
{
    int n,m;
    scanf("%d%d",&n,&m);
    int sum[100005];
    sum[0]=0;
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&sum[i]);
        sum[i]+=sum[i-1];
    }
    int minn=0x3f3f3f3f;
     for(int i=1;i<=n;i++)
     {
         int low=i,high=n,mid;
         while(low<=high)
         {
             mid=(low+high)/2;
             if(sum[mid]-sum[i-1]<m)
                low=mid+1;
             else
                high=mid-1;
         }
         if(sum[low]-sum[i-1]>=m)
         {
             if(sum[low]-sum[i-1]<minn)
             {
                 minn=sum[low]-sum[i-1];
                 ans.clear();
                 Node node;
                 node.x=i;node.y=low;
                 ans.push_back(node);
             }else if(sum[low]-sum[i-1]==minn)
             {
                 Node node;
                 node.x=i;node.y=low;
                 ans.push_back(node);
             }
         }
     }
     for(int i=0;i<ans.size();i++)
     {
         printf("%d-%d\n",ans[i].x,ans[i].y);
     }
     return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值