1044 Shopping in Mars (25 分)-PAT甲级

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤105), the total number of diamonds on the chain, and M (≤108), the amount that the customer has to pay. Then the next line contains N positive numbers D1​⋯DN​ (Di​≤103 for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of i ≤ j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + ... + Dj >M with (Di + ... + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

 题目大意:给定一串序列,要求找出子序列和等于M的全部区间,如果找不到这样的子区间,那就找出存在大于M的最小序列和的全部区间。

思路:二重循环+数组前缀和也会超时,考虑使用二分查找或者双指针法,二分查找法会在今后更新,这里使用双指针法

维护一个[i, j)的子区间的和,记为sum,初始化为0,如果sum < M,就让sum += a[j](增加sum的值),j++;如果sum > M ,就让sum -= a[i](减少sum的值),i++;如果sum == M,就输出区间[i, j - 1),并且让i++(为了打破sum == M的平衡,避免陷入死循环) ,重复以上过程,循环条件为 j < N || j == N && sum >= M

双指针法可以有效避免二重循环因无效枚举而带来的多余时间问题,大大提高时间效率!

改天试一下二分查找法

 AC代码

#include <iostream>
using namespace std;
int main() {
    int M, N;
    cin >> N >> M;
    int a[100000];
    int Min = 9999999; // 大于或者等于15的最小整数
    for (int i = 0; i < N; i++) cin >> a[i];
    for (int i = 0, j = 0, sum = 0;j < N || sum >= M;) {
        if (sum < M) { // sum小于M,j指针后移
            sum += a[j];
            if (sum < Min && sum >= M) Min = sum; // 更新Min
            j++;
        }
        else if (sum > M) { // sum大于M,i指针后移
            sum -= a[i];
            if (sum < Min && sum >= M) Min = sum;
            i++;
        }
        else {
            cout << i + 1 << "-" << j << endl;
            if (sum < Min && sum >= M) Min = sum;
                sum -= a[i];
            i++; //为了避免陷入死循环,将i++
        }
    }
    if (Min == M) return 0;// 意味着存在M,并且前面已经输出
    M = Min;//不存在M时,将M的值更新为Min后,重复上面的步骤
    for (int i = 0, j = 0, sum = 0; j < N || sum >= M; ) {
        if (sum < M) {
            sum += a[j];
            j++;
        }
        else if (sum > M) {
            sum -= a[i];
            i++;
        }
        else {
            cout << i + 1 << "-" << j << endl;
            sum -= a[i];
            i++;
        }
    }
}

 更多PAT甲级题目:请访问PAT甲级刷题之路--题目索引+知识点分析(正在进行),感谢支持!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值