PAT甲级-1051 Pop Sequence (stack模拟)

1051 Pop Sequence (25 分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

//题意:给你你个大小为m的栈,1-n个数字的递增排列,以及k个排列;要求你判断是否能根据这个栈的出栈,入栈操作实现这个排列; 

//思路:模拟,将1-n按顺序入栈,有以下三种情况要求出栈操作:1.栈满的时候。2.n个数都放进栈的时候。3.当栈顶数和a[index]相等的时候;            当序列中的n个数都被匹配完时停止循环;

//错误原因见代码;

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<stack>
using namespace std;
stack<int>st;
int main()
{
    int m,n,k;
    scanf("%d%d%d",&m,&n,&k);
    for(int i=0;i<k;i++)
    {
        int a[1005];
        for(int j=1;j<=n;j++)scanf("%d",&a[j]);
        while(!st.empty())st.pop();
        st.push(1);
        int num=2,j=1,flag=1;
        while(j<=n)
        {
            //cout<<st.top()<<" "<<a[j]<<" "<<st.size()<<" "<<j<<endl;
            //cout<<1<<"***"<<endl;
            if(num>n)
            {
                //cout<<"1**"<<endl;
                while(!st.empty())
                {
                    if(st.top()!=a[j])
                    {
                        flag=0;
                        break;
                    }else
                    {
                        st.pop();j++;
                    }
                }
                //if(j>n)break;
                if(flag==0)break;
            }
            if(st.size()==m)
            {
                //cout<<"2**"<<endl;
                if(st.top()!=a[j])
                {
                    flag=0;
                    break;
                }else
                {
                    st.pop();
                    j++;
                }
            }
            while((!st.empty())&&st.top()==a[j])//刚开始写成while(st.top()==a[j]&&!st.empty());一直运行出错,因为此时栈为空,st.top()没有东西,st.top()==a[j]就会出错;
            {
                //cout<<"3**"<<endl;
                st.pop();
                j++;
                //if(st.size()==0)break;
                //cout<<st.size()<<endl;
            }
            //cout<<"4**"<<endl;
            st.push(num);
            num++;
            //cout<<"j:"<<j<<endl;
        }
        if(flag==0)printf("NO\n");
        else printf("YES\n");
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值