PAT-A1051 Pop Sequence 题目内容及题解

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

题目大意

题目给定了一个能容纳M个元素的栈和从1到N的入栈序列,要求判断题目给出的序列是否可能是给定栈的出栈序列。

解题思路

  1. 模拟一个栈,逐个读取出栈序列,并作出判断,依次输出,并返回零值;
  2. 给定栈空间可能为零(边界条件);
  3. 不论是否为出栈序列,必须将序列中所有数字读入,否则影响下一次判定。

代码

#include<stdio.h>
#define maxn 1010
int main(){
    int N,M,K;
    int i;
    int stack[maxn],top,current,flag,num;
    scanf("%d%d%d",&M,&N,&K);
    stack[M]=-1;
    while(K--){
        top=-1;
        flag=1;
        num=1;
        if(M>0){
            stack[++top]=1;
        }else{
            printf("NO\n");
        }
        for(i=0;i<N;i++){
            scanf("%d",&current);
            if(flag){
                while(top<M-1&&num<N&&(stack[top]<current||top==-1)){
                    stack[++top]=++num;
                }
                if(stack[top]==current){
                    top--;
                }else{
                    flag=0;
                }
            }
        }
        if(flag==0){
            printf("NO\n");
        }else{
            printf("YES\n");
        }
    }
    return 0;
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值