1043 Is It a Binary Search Tree (25 分)(判断是不是二叉搜索树)

1043 Is It a Binary Search Tree (25 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

//先建树,再前序输出判断;

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<vector>
using namespace std;
vector<int>ans;
int n;
struct Node
{
    Node *l;
    Node *r;
    int val;
    Node()
    {
        l=NULL;
        r=NULL;
    }
};
Node* _insert1(Node *node,int k)
{
    if(node==NULL)
    {
        node=new Node;
        node->val=k;
    }else
    {
        if(k<node->val)node->l=_insert1(node->l,k);
        else node->r=_insert1(node->r,k);
    }
    return node;
}
void buildbst1(Node *root,int *a)
{
    for(int i=1;i<n;i++)
    {
        _insert1(root,a[i]);
    }
}
Node* _insert2(Node *node,int k)
{
    if(node==NULL)
    {
        node=new Node;
        node->val=k;
    }else
    {
        if(k>=node->val)node->l=_insert2(node->l,k);
        else node->r=_insert2(node->r,k);
    }
    return node;
}
void buildbst2(Node *root,int *a)
{

    for(int i=1;i<n;i++)
    {
        _insert2(root,a[i]);
    }
}
void pre(Node *root)
{
    if(root==NULL)
        return;
    //cout<<"**"<<root->val<<endl;
    ans.push_back(root->val);
    pre(root->l);
    pre(root->r);

}
void showpost(Node *root)
{
    if(root==NULL)
        return;
    showpost(root->l);
    showpost(root->r);
    ans.push_back(root->val);
}
int main()
{
    int flag;
    int a[1005];
    scanf("%d",&n);
    for(int i=0;i<n;i++)scanf("%d",&a[i]);
    Node *root=new Node;
    root->val=a[0];
    buildbst1(root,a);
    //cout<<(root->r->val)<<"*"<<endl;
    ans.clear();
    pre(root);
    for(int i=0;i<n;i++)
    {
        if(ans[i]!=a[i])
        {
            flag=0;
            break;
        }else
        {
            flag=1;
        }
    }
    if(flag==1)
    {
        printf("YES\n");
        ans.clear();
        showpost(root);
        for(int i=0;i<n;i++)
        {
            printf("%d",ans[i]);
            if(i==n-1)printf("\n");
            else printf(" ");
        }
    }else
    {
        Node *root1=new Node;
        root1->val=a[0];
        buildbst2(root1,a);
        ans.clear();
        pre(root1);
        for(int i=0;i<n;i++)
        {

            if(ans[i]!=a[i])
            {
                flag=0;
                break;
            }else
            {
                flag=1;
            }
        }
        if(flag==0)printf("NO\n");
        else
        {
            printf("YES\n");
            ans.clear();
            showpost(root1);
            for(int i=0;i<n;i++)
            {
                printf("%d",ans[i]);
                if(i==n-1)printf("\n");
                else printf(" ");
            }
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
以下是实现该功能的 C 代码: ```c #include <stdio.h> #include <stdbool.h> #include <stdlib.h> // 定义二叉树结构体 struct TreeNode { int val; struct TreeNode *left; struct TreeNode *right; }; // 中序遍历二叉树并判断是否为二叉搜索树 bool inorderTraversal(struct TreeNode *root, int *prev) { if (root == NULL) { return true; } if (!inorderTraversal(root->left, prev)) { return false; } if (root->val <= *prev) { return false; } *prev = root->val; return inorderTraversal(root->right, prev); } bool isValidBST(struct TreeNode* root){ int prev = INT_MIN; return inorderTraversal(root, &prev); } // 创建二叉树 struct TreeNode* createTree(int *arr, int start, int end) { if (start > end) { return NULL; } int mid = (start + end) / 2; struct TreeNode *root = (struct TreeNode*)malloc(sizeof(struct TreeNode)); root->val = arr[mid]; root->left = createTree(arr, start, mid-1); root->right = createTree(arr, mid+1, end); return root; } // 打印中序遍历序列 void inorderPrint(struct TreeNode *root) { if (root == NULL) { return; } inorderPrint(root->left); printf("%d ", root->val); inorderPrint(root->right); } // 测试代码 int main() { int arr[] = {1, 2, 3, 4, 5, 6, 7}; int len = sizeof(arr) / sizeof(arr[0]); struct TreeNode *root = createTree(arr, 0, len-1); inorderPrint(root); printf("\nThis tree is %s a binary search tree.\n", isValidBST(root) ? "" : "not"); return 0; } ``` 该程序首先利用给定的数组创建一棵平衡二叉搜索树,然后打印出它的中序遍历序列。最后,利用 `inorderTraversal` 函数判断该二叉树是否为二叉搜索树。 需要注意的是,该程序中的 `inorderTraversal` 函数利用了指向前驱节点的指针 `prev`,用于判断当前节点和它的前驱节点的大小关系。在最开始调用 `isValidBST` 函数时,将 `prev` 初始化为整型最小值 `INT_MIN`。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值