1110 Complete Binary Tree (25 分)

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤20) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NO and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

Sample Output 1:

YES 8

Sample Input 2:

8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

Sample Output 2:

NO 1

//题意:给你一棵树:要求你判断是不是一棵完全二叉树,若是,输出左后一个节点,否则,输出根节点;

//思路:层次遍历给每个节点编号,然后再层次遍历输出,看前后节点的编号是否连续 

//坑点:n可能为两位数,所以输入数字用char a[2],

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<queue>
#include<vector>
using namespace std;
struct Node
{
    int father;
    char l[3];
    char r[3];
    int id;
    Node()
    {
        father=-1;
    }
};
int f(char a[])
{
    int sum=0;
    for(int i=0;i<strlen(a);i++)
        sum=sum*10+a[i]-'0';
    return sum;
}
int main()
{
    vector<int>ans;
    ans.clear();
    int n;
    scanf("%d",&n);
    Node node[30];
    for(int i=0;i<n;i++)
    {
        getchar();
        scanf("%s %s",node[i].l,node[i].r);
        if(node[i].l[0]!='-')
            node[f(node[i].l)].father=i;
        if(node[i].r[0]!='-')
            node[f(node[i].r)].father=i;
    }
    int root;
    for(int i=0;i<n;i++)
    {
        if(node[i].father==-1)
        {
            root=i;
            break;
        }
    }
    queue<int>q;
    while(!q.empty())q.pop();
    q.push(root);
    int last=root;
    node[root].id=1;
    while(!q.empty())
    {
        int index=q.front();
        ans.push_back(node[index].id);
        last=index;
        q.pop();
        if(node[index].l[0]!='-')
        {
            int t1=f(node[index].l);
            node[t1].id=node[index].id*2;
            q.push(t1);
        }
        if(node[index].r[0]!='-')
        {
            int t1=f(node[index].r);
            node[t1].id=node[index].id*2+1;
            q.push(t1);
        }
    }
    int flag=1;
    for(int i=1;i<ans.size();i++)
    {
        if(ans[i]-ans[i-1]==1)
            flag=1;
        else
        {
            flag=0;
            break;
        }
    }
    if(flag==1)printf("YES %d",last);
    else printf("NO %d\n",root);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值