1110 Complete Binary Tree

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤20) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NO and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

Sample Output 1:

YES 8

Sample Input 2:

8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

Sample Output 2:

NO 1

判断是否是完全二叉树:首先树的高度和结点个数满足 n >= power(2, h - 1) && n <= (power(2, h) - 1),其次最下面一层的结点必须是从左到右依次排列的,即倒数第二层的结点不能只有右子树而没有左子树,可以只有左子树,而且如果序号在前的结点已经没有左右子树了,序号在后的结点就不能再有左右子树。

#include <iostream>
#include <vector>
#include <string>
#include <stdlib.h>
#include <queue>
using namespace std;
int n, root, cnt, last, h;
string l, r;
bool vis[50];
bool flag;

struct node {
	int val, left, right;
} a[50];
queue<node>q;

int power(int x, int y) {
	int ans = 1;
	while (y > 0) {
		if (y & 1) {
			ans *= x;
		}
		x *= x;
		y >>= 1;
	}
	return ans;
}

void dfs(int x, int d) {
	h = max(h, d);
	if (a[x].left != -1) {
		dfs(a[x].left, d + 1);
	}
	if (a[x].right != -1) {
		dfs(a[x].right, d + 1);
	}
}

int main() {
	cin >> n;
	for (int i = 0; i < n; i++) {
		cin >> l >> r;
		a[i].val = i;
		if (l == "-") {
			a[i].left = -1;
		} else {
			a[i].left = atoi(l.c_str());
			vis[atoi(l.c_str())] = 1;
		}
		if (r == "-") {
			a[i].right = -1;
		} else {
			a[i].right = atoi(r.c_str());
			vis[atoi(r.c_str())] = 1;
		}
		if (a[i].left == -1 && a[i].right != -1) {
			flag = 1;
		}
	}
	for (int i = 0; i < n; i++) {
		if (!vis[i]) {
			root = i;
			break;
		}
	}
	if (flag) {
		cout << "NO " << root;
		return 0;
	}
	dfs(root, 1);
	if (!(n >= power(2, h - 1) && n <= (power(2, h) - 1))) {
		cout << "NO " << root;
		return 0;
	}
	q.push(a[root]);
	bool child = 1;
	while (!q.empty()) {
		int u = q.front().val;
		cnt++;
		q.pop();
		if (a[u].left != -1) {
			q.push(a[a[u].left]);
		}
		if (a[u].right != -1) {
			q.push(a[a[u].right]);
		}
		if (a[u].left != -1 && !child) {
			flag = 1;
		}
		if (a[u].right == -1 && child) {
			child = 0;
		}
		if (cnt == n) {
			last = u;
		}
	}
	if (flag) {
		cout << "NO " << root;
	} else {
		cout << "YES " << last;
	}
	return 0;
}

 

To convert the given array to a complete BST, we need to perform the following steps: 1. Sort the array in ascending order 2. Construct a complete binary tree using the sorted array 3. Perform inorder traversal of the binary tree and store the elements in the original array in the same order as the traversal Here's the implementation of the to_bst(lst) function in Python: ```python def to_bst(lst): # Sort the input list lst.sort() # Construct a complete binary tree using the sorted list n = len(lst) if n == 0: return lst root = lst[n // 2] left_subtree = to_bst(lst[:n // 2]) right_subtree = to_bst(lst[n // 2 + 1:]) binary_tree = [root] + left_subtree + right_subtree # Perform inorder traversal of the binary tree and store the elements in the original array inorder_traversal(binary_tree, lst, 0) return lst def inorder_traversal(binary_tree, lst, i): # Perform inorder traversal of the binary tree and store the elements in the original array n = len(binary_tree) if i >= n: return inorder_traversal(binary_tree, lst, 2 * i + 1) lst[i] = binary_tree[i] inorder_traversal(binary_tree, lst, 2 * i + 2) ``` The to_bst(lst) function takes in the input list and returns the same list after converting it to a complete BST. The function first sorts the input list in ascending order. It then constructs a complete binary tree using the sorted list by recursively dividing the list into two halves and setting the middle element as the root of the binary tree. Finally, the function performs an inorder traversal of the binary tree and stores the elements in the original list in the same order as the traversal.
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值