Machine Schedule 【最小顶点覆盖】

Machine Schedule

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8858 Accepted Submission(s): 4449

Problem Description
As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine’s working mode from time to time, but unfortunately, the machine’s working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines.

Input
The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.

Output
The output should be one integer per line, which means the minimal times of restarting machine.

Sample Input
5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0

Sample Output
3

Source
Asia 2002, Beijing (Mainland China)
最小顶点覆盖就是 在二分图中,选取最少的 点,让这些点可以和所有的边都关联
比如这道题,
e g
1 2 3 // job 1 可以让x 2 or y 3 完成
2 2 4

则 最小点覆盖 可以选择 x 2 就可以完成所有的任务
(注意 如果都是0 ,我们可以让所有 可以为0的先做,这样就不用转换)
思路: 性质 最小顶点覆盖==最大匹配
代码

#include<stdio.h>
#include<string.h>
#include<math.h>
#define M 1000+110
#define MOD 100000007
#define LL long long
int used[M],mapp[M][M],pei[M];
    int n,m,k;
int find(int x)
{
    int j,i;
    for(i=0;i<m;i++)
    {
        if(!used[i]&&mapp[x][i])
        {
            used[i]=1;
            if(!pei[i]||find(pei[i]))
            {
                pei[i]=x;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{

    while(scanf("%d",&n)&&n)
    {
        scanf("%d%d",&m,&k);
        int i,j;
        memset(mapp,0,sizeof(mapp));
        memset(pei,0,sizeof(pei));
        for(i=0;i<k;i++)
        {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            if(b&&c) //  如果有0 可以跳过
            mapp[b][c]=1;
        }

        int sum=0;
        for(i=0;i<n;i++)
        {
        memset(used,0,sizeof(used));
        if(find(i)) sum++;      
        }
        printf("%d\n",sum);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值