Labyrinth 【迷宫图中 树的直径应用】

Labyrinth
Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 3990 Accepted: 1501
Description
The northern part of the Pyramid contains a very large and complicated labyrinth. The labyrinth is divided into square blocks, each of them either filled by rock, or free. There is also a little hook on the floor in the center of every free block. The ACM have found that two of the hooks must be connected by a rope that runs through the hooks in every block on the path between the connected ones. When the rope is fastened, a secret door opens. The problem is that we do not know which hooks to connect. That means also that the neccessary length of the rope is unknown. Your task is to determine the maximum length of the rope we could need for a given labyrinth.
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers C and R (3 <= C,R <= 1000) indicating the number of columns and rows. Then exactly R lines follow, each containing C characters. These characters specify the labyrinth. Each of them is either a hash mark (#) or a period (.). Hash marks represent rocks, periods are free blocks. It is possible to walk between neighbouring blocks only, where neighbouring blocks are blocks sharing a common side. We cannot walk diagonally and we cannot step out of the labyrinth.
The labyrinth is designed in such a way that there is exactly one path between any two free blocks. Consequently, if we find the proper hooks to connect, it is easy to find the right path connecting them.
Output
Your program must print exactly one line of output for each test case. The line must contain the sentence “Maximum rope length is X.” where Xis the length of the longest path between any two free blocks, measured in blocks.
Sample Input
2
3 3

#

.

#

7 6
*#######

.#.

.#.

.#.#.

…..

#*

Sample Output
Maximum rope length is 0.
Maximum rope length is 8.
Hint
Huge input, scanf is recommended.
If you use recursion, maybe stack overflow. and now C++/c ‘s stack size is larger than G++/gcc

题意 :找到图中 距离最远的 ‘ . ’与‘ . ’的距离

树的直径

代码

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<cmath>
#include<queue>
#include<stack>
#include<map>
#include<vector>
#include<set>
#define CLR(a,b) memset((a),(b),sizeof(a))
#define inf 0x3f3f3f3f
#define mod 100009
#define LL long long
#define MAXN  1000+10
#define MAXM 2000000+100
#define ll o<<1
#define rr o<<1|1
#define lson o<<1,l,mid
#define rson o<<1|1,mid+1,r
using namespace std;
void read(int &x){
    x=0;char c;
    while((c=getchar())<'0');
    do x=x*10+c-'0';while((c=getchar())>='0');
}
typedef struct Node{
    int x,y,step;
}node[MAXM];
int mp[1005][1005];  
int vis[1005][1005];
int to[4][2]={1,0,-1,0,0,1,0,-1};// 移动的方向 
int n,m; 
int ans;// 最长距离 
Node S;  //第二次bfs的起点 
Node st; // 第一次bfs的起点 
void init()
{
    memset(mp,0,sizeof(mp));
    memset(vis,0,sizeof(vis));
}
void getmap()
{
    for(int i=1;i<=n;i++)
    {
        getchar();
        for(int j=1;j<=m;j++)
        {
            char c;
            scanf("%c",&c);
            if(c=='.' ) 
            {
                mp[i][j]=1;  //mp中0的意义为 边界和 #  
                st.x=i;  // 随便找到一个 为 ‘.’的坐标 
                st.y=j;
            }
        }
     }
}
void bfs(Node sx)
{
    ans=0; 
    queue<Node>Q;vis[sx.x][sx.y]=1;
    sx.step=0;
    while(!Q.empty())
    {
        Node now=Q.front();Q.pop();
        for(int i=0;i<4;i++)
        {
            Node nexts;
            nexts.x=now.x+to[i][1];
            nexts.y=now.y+to[i][0];
            if(!vis[nexts.x][nexts.y]&&mp[nexts.x][nexts.y])
            {
                vis[nexts.x][nexts.y]=1;
                nexts.step=now.step+1;
                if(ans<nexts.step)
                {
                    ans=nexts.step;
                    S.x=nexts.x;
                    S.y=nexts.y;
                }
                Q.push(nexts);
            }
        }
    }
}
void solve()
{
    bfs(st);
    bfs(S);
    printf("Maximum rope length is %d.\n",ans);
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        cin>>n>>m;
        init();
        getmap();
        solve();
     } 
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值