Triangle LOVE 【topo 判有无环】

Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). A i,j = 1 means i-th people loves j-th people, otherwise A i,j = 0.
It is guaranteed that the given relationship is a tournament, that is, A i,i= 0, A i,j ≠ A j,i(1<=i, j<=n,i≠j).
Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
Sample Input
2
5
00100
10000
01001
11101
11000
5
01111
00000
01000
01100
01110
Sample Output
Case #1: Yes
Case #2: No

题意 给一个有向图,问其中是不是有环。
可以用topo
(无语的是,我用链式向前星存图,却TLE改为邻接表存,就能过。)
代码

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
const int MAXN =2000+100;
vector<int>G[MAXN];
int n;
int in[MAXN];
void init(){
    for(int i=0;i<=n;i++)
    {
        G[i].clear();
        in[i]=0;
    }
}
void getmap(){
    char s[MAXN];
    for(int i=1;i<=n;i++){
        scanf("%s",s);
        for(int j=0;j<n;j++){
            if(s[j]=='1') {
                G[i].push_back(j+1);
                in[j+1]++;
            }
        }
    }
}
bool topo(){
    queue<int>Q;
    for(int i=1;i<=n;i++)
        if(in[i]==0) Q.push(i);
        int num=0;
    while(!Q.empty()){
        int now=Q.front();Q.pop();num++;
        for(int i=0;i<G[now].size();i++){
            if(--in[G[now][i]]==0)
                Q.push(G[now][i]);
        }
    }
    return num!=n;
}
int main(){
    int k=1;
    int t;scanf("%d",&t);while(t--){
        scanf("%d",&n);
        init();
        getmap();
        printf("Case #%d: %s\n",k++,topo()?"Yes":"No");
    }

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值