【poj 1679】The Unique MST 【次小生成树 模板】

Given a connected undirected graph, tell if its minimum spanning tree is unique.

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V’, E’), with the following properties:
1. V’ = V.
2. T is connected and acyclic.

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E’) of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E’.
Input
The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.
Output
For each input, if the MST is unique, print the total cost of it, or otherwise print the string ‘Not Unique!’.
Sample Input
2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2
Sample Output
3
Not Unique!

模板连接

题意 : 给定n个点m条边的图,求最小生成树,如果最小生成树不唯一那么就输出Not Unique!,否则就输出最小生成树的值;
代码

#include<cstdio>
#include<string.h>
#include<iostream>
#include<math.h> 
using namespace std;
#define LL long long 
const int inf = 0x3f3f3f3f;
const int MAXN =200+10;
const int MAXM =1e8;
/*------------------------------*/
int mp[MAXN][MAXN];
bool vis[MAXN];
int dis[MAXN];
int mst[MAXN][MAXN];//记录生成树中,i到j路中最大的权值是多少。
bool Inmst[MAXN][MAXN];//记录边是不是在生成树中
int pre[MAXN];//记录每个点的前驱
int n,m;
void init(){
    for(int i=1;i<=n;i++){
        for(int j=1;j<i;j++){
            if(i==j ) mp[i][j]=0;
            else mp[i][j]=mp[j][i]=inf;
        }
    }
}
void getmap(){
    int a,b,c;
    while(m--){
        scanf("%d%d%d",&a,&b,&c);
        if(mp[a][b]>c){ //防止重边
            mp[a][b]=mp[b][a]=c;
        }
    }
}
void solve(){ // prime算法求最小生成树
    memset(mst,0,sizeof(mst));
    memset(Inmst,0,sizeof(Inmst));
    for(int i=1;i<=n;i++){
        dis[i]=mp[1][i]; //默认选择 1为起始点
        vis[i]=0;
        pre[i]=1;
    }
    vis[1]=1;int minn,nexts;int mincost=0;
    for(int i=2;i<=n;i++){
          minn=inf;nexts=-1;
          for(int j=1;j<=n;j++){
            if(!vis[j]&&minn>dis[j]) {
                minn=dis[j];
                nexts=j;
              }
          }
          vis[nexts]=1;mincost+=minn;int fa=pre[nexts];
          Inmst[fa][nexts]=Inmst[nexts][fa]=1;
          for(int j=1;j<=n;j++){
              if(vis[j]&&j!=nexts) mst[nexts][j]=mst[j][nexts]=max(mp[fa][nexts],dis[j]); //更新 mst
              if(!vis[j]&&dis[j]>mp[nexts][j]) {
                    dis[j]=mp[nexts][j];
                    pre[j]=nexts;//更新前驱
                }
          }
    }
    for(int i=1;i<=n;i++){ // 枚举边
        for(int j=1;j<i;j++){
            if(mp[i][j]!=inf&&!Inmst[i][j]){//有这个边,但是却不在生成树中
                if(mp[i][j]==mst[i][j]){//可以被替代
                    puts("Not Unique!");
                    return ;
                } 
            }
        }
    }
    printf("%d\n",mincost);
}
int main(){
        int t;cin>>t;
        while(t--){
             scanf("%d%d",&n,&m);
            init();
            getmap();
            solve();
        }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值