【HDU 6187 】Destroy Walls 【平面图+最大生成树】

Destroy Walls

Time Limit: 8000/4000 MS (Java/Others) Memory Limit: 132768/132768 K (Java/Others)
Total Submission(s): 287 Accepted Submission(s): 125

Problem Description
Long times ago, there are beautiful historic walls in the city. These walls divide the city into many parts of area.

Since it was not convenient, the new king wants to destroy some of these walls, so he can arrive anywhere from his castle. We assume that his castle locates at (0.6∗2√,0.6∗3√).

There are n towers in the city, which numbered from 1 to n. The ith’s location is (xi,yi). Also, there are m walls connecting the towers. Specifically, the ith wall connects the tower ui and the tower vi(including the endpoint). The cost of destroying the ith wall is wi.

Now the king asks you to help him to divide the city. Firstly, the king wants to destroy as less walls as possible, and in addition, he wants to make the cost least.

The walls only intersect at the endpoint. It is guaranteed that no walls connects the same tower and no 2 walls connects the same pair of towers. Thait is to say, the given graph formed by the walls and towers doesn’t contain any multiple edges or self-loops.

Initially, you should tell the king how many walls he should destroy at least to achieve his goal, and the minimal cost under this condition.

Input
There are several test cases.

For each test case:

The first line contains 2 integer n, m.

Then next n lines describe the coordinates of the points.

Each line contains 2 integers xi,yi.

Then m lines follow, the ith line contains 3 integers ui,vi,wi

|xi|,|yi|≤105

3≤n≤100000,1≤m≤200000

1≤ui,vi≤n,ui≠vi,0≤wi≤10000

Output
For each test case outout one line with 2 integers sperate by a space, indicate how many walls the king should destroy at least to achieve his goal, and the minimal cost under this condition.

Sample Input
4 4
-1 -1
-1 1
1 1
1 -1
1 2 1
2 3 2
3 4 1
4 1 2

Sample Output
1 1

Source
2017ACM/ICPC广西邀请赛-重现赛(感谢广西大学)

补充知识点
1 平面图
   能够画在平面上,任何两条边除了端点之外没有其他交点,这样的图叫做平面图,但有的图表面有交点,只要改变画法就会没有交点,这样的图也是平面图。
2 非平面图
  一个图不管它图形的几何形状如何改变,除结点处外,它们的边总有交叉现象出现,这样的图是非平面图。

题意, 给一个无向的平面图,然后问至少拆掉几条边才可以让人到达所有区域,同时拆掉的边的总花费最小。
可以知道,最后拆完后的图为一个连通图且是无环的,故可知最后图为一棵树,又因为想要拆的总花费最小,所以我们要保留花费最大的树 。
代码

#include<bits/stdc++.h>
#define LL long long 
using namespace std;

const int MAXN = 100000+10;
const int MAXM =  200000+100 ;
const int mod  = 1e9+7;
const int inf = 0x3f3f3f3f;

struct Edge {
    int from,to,val;
}edge[MAXM];
int pre[MAXN];
bool cmp(Edge a,Edge b){
    return a.val>b.val;
}
int n,m;
void init(){
    for(int i=0;i<=n+10;i++) pre[i]=i;
}
int Find(int x){ return  pre[x]==x?x:pre[x]=Find(pre[x]) ; } 
int main(){
    while(~scanf("%d%d",&n,&m)){
        int a,b;init(); LL ans=0;
        for(int i=1;i<=n;i++) scanf("%d%d",&a,&b);
        for(int i=0;i<m;i++) {
            scanf("%d%d%d",&edge[i].from,&edge[i].to,&edge[i].val);
            ans+=edge[i].val;
        }
        sort(edge,edge+m,cmp);
        int cnt=0;
        for(int i=0;i<m;i++){
            Edge e =edge[i];
            a=Find(e.from); b=Find(e.to);
            if(a!=b) {
                ans-=e.val; pre[a]=b;
                cnt++;  
            }
        }
        printf("%d %lld\n",m-cnt,ans);
    } 
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值