【hdu 4497】GCD and LCM 【算术基本定理】

Problem Description
Given two positive integers G and L, could you tell me how many solutions of (x, y, z) there are, satisfying that gcd(x, y, z) = G and lcm(x, y, z) = L?
Note, gcd(x, y, z) means the greatest common divisor of x, y and z, while lcm(x, y, z) means the least common multiple of x, y and z.
Note 2, (1, 2, 3) and (1, 3, 2) are two different solutions.

Input
First line comes an integer T (T <= 12), telling the number of test cases.
The next T lines, each contains two positive 32-bit signed integers, G and L.
It’s guaranteed that each answer will fit in a 32-bit signed integer.

Output
For each test case, print one line with the number of solutions satisfying the conditions above.

Sample Input
2
6 72
7 33

Sample Output
72
0

Source
2013 ACM-ICPC吉林通化全国邀请赛——题目重现

Recommend
liuyiding
就是一点 算术基本定理 一个正整数 n 一定可以分解为
n=p1^r1*p2^r2*p3^r3……pn^rn (其中p1p2p3..pn 都是素数)
还有一个公式
IF gcd(a,b)==d to gcd(a/d,b/d)==1 。

这个的题解讲的很清楚了
代码

#include<bits/stdc++.h>
#define LL long long
using namespace std;
const int MAXN = 500+10;
const int MAXM = 1e5;
LL g,l;
LL p[50],ge;
LL r[50];
void getn(int m){
    ge=0;LL n=m;
    memset(r,0,sizeof(r));
    for(LL i=2;i*i<=n;i++){
        if(n%i==0){
            p[ge]=i;
            while(n%i==0) {
            r[ge]++;n/=i;
            }
            ge++;
            //printf("i==%d\n",i)   ;
        }
    }
    if(n>1) {  p[ge]=n;  r[ge++]++;  }
}
int main(){
    int t;cin>>t;
    while(t--){
        scanf("%lld%lld",&g,&l);
        LL cnt=1;
        if(l%g) { puts("0");continue;}
        getn(l/g);
        for(int i=0;i<ge;i++) 
            cnt=cnt*6*r[i];
        printf("%lld\n",cnt);
    }  
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值