【2017 ACM-ICPC 亚洲区(乌鲁木齐赛区)网络赛 】H Skiing 【求DAG图的最长路】

In this winter holiday, Bob has a plan for skiing at the mountain resort.

This ski resort has MM different ski paths and NN different flags situated at those turning points.

The ii-th path from the S_iS
​i
​​ -th flag to the T_iT
​i
​​ -th flag has length L_iL
​i
​​ .

Each path must follow the principal of reduction of heights and the start point must be higher than the end point strictly.

An available ski trail would start from a flag, passing through several flags along the paths, and end at another flag.

Now, you should help Bob find the longest available ski trail in the ski resort.

Input Format

The first line contains an integer TT, indicating that there are TT cases.

In each test case, the first line contains two integers NN and MM where 0 < N \leq 100000 < N ≤ 10000 and 0 < M \leq 1000000 < M ≤ 100000 as described above.

Each of the following MM lines contains three integers S_iS
​i TiTi​​ , and L_i~(0 < L_i < 1000) Li (0 < L i <1000) describing a path in the ski resort.

Output Format

For each test case, ouput one integer representing the length of the longest ski trail.

样例输入

1
5 4
1 3 3
2 3 4
3 4 1
3 5 2
样例输出

6
题意 给n个点和m条边的DAG图,问图中的最长路。
我们可以用topo序来求。
代码

#include<bits/stdc++.h>
using namespace std ;
typedef long long LL ;

const int MAXN = 10000+10 ;
const int MAXM = 100000+10 ;
const int mod  = 1e9+7 ;

struct Edge {
    int from,to,val,next;
}edge[MAXM];
int head[MAXN],top;
void init(){
    memset(head,-1,sizeof(head));
    top=0;
}
void addedge(int a,int b,int c){
    edge[top].from=a;edge[top].to=b;
    edge[top].val=c;edge[top].next=head[a];
    head[a]=top++;
} 

int n,m;
int in[MAXN];
int val[MAXN];
void work(){
    queue<int>Q;
    memset(val,0,sizeof(val));
    for(int i=1;i<=n;i++) if(!in[i]) Q.push(i);
    while(!Q.empty()){
        int now=Q.front();Q.pop();
        for(int i=head[now];i!=-1;i=edge[i].next){
            Edge e=edge[i];
            val[e.to]=max(val[e.to],val[now]+e.val);// DP思想
            if(--in[e.to]==0) Q.push(e.to);
        }
    }
    int ans=0; 
    for(int i=1;i<=n;i++) ans=max(ans,val[i]);
    printf("%d\n",ans);
}

int main(){
    int T;scanf("%d",&T);
    while(T--){
        init();
        memset(in,0,sizeof(in)) ;
        scanf("%d%d",&n,&m);
        while(m--){
            int a,b,c;scanf("%d%d%d",&a,&b,&c);
            addedge(a,b,c);
            in[b]++;
        }
        work();
    }
    return  0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
ACM-ICPC(国际大学生程序设计竞)是一项面向大学生的计算机编程竞,涉及算法和数据结构等领域。在比中,选手需要解决一系列编程问题,使用合适的算法和数据结构来实现正确和高效的解决方案。 对于整理ACM-ICPC模板,以下是一些建议: 1. 了解比:首先,你需要了解ACM-ICPC的具体要和规则。这包括了解比所涉及的算法和数据结构,以及题目的类型和难度等。 2. 收集资料:收集与ACM-ICPC相关的资料,包括经典算法和数据结构的实现代码、常见问题的解题思等。可以参考教材、博客、论文等资源。 3. 整理模板:将收集到的资料整理成模板。可以按照算法和数据结构的分类进行整理,例如排序算法、算法、字符串算法等。对每个模板,添加必要的注释和示例代码,以便理解和使用。 4. 测试代码:对每个模板编写测试代码,确保它们的正确性和可靠性。可以使用已知的测试用例或自行设计测试用例。 5. 更新与扩充:定期更新和扩充模板,以适应ACM-ICPC中新出现的算法和数据结构。同时,根据自己的经验和理解,对模板进行优化和改进。 6. 练习和复习:在比之前,利用整理好的模板进行练习和复习。尝试解决一些经典问题,使用模板中的算法和数据结构进行实现,并进行优化。 希望这些建议对你整理ACM-ICPC模板有所帮助!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值