【POJ - 3270 】Cow Sorting 【置换群 序列变升序最小花费】

Farmer John’s N (1 ≤ N ≤ 10,000) cows are lined up to be milked in the evening. Each cow has a unique “grumpiness” level in the range 1…100,000. Since grumpy cows are more likely to damage FJ’s milking equipment, FJ would like to reorder the cows in line so they are lined up in increasing order of grumpiness. During this process, the places of any two cows (not necessarily adjacent) can be interchanged. Since grumpy cows are harder to move, it takes FJ a total of X+Y units of time to exchange two cows whose grumpiness levels are X and Y.

Please help FJ calculate the minimal time required to reorder the cows.

Input
Line 1: A single integer: N.
Lines 2.. N+1: Each line contains a single integer: line i+1 describes the grumpiness of cow i.
Output
Line 1: A single line with the minimal time required to reorder the cows in increasing order of grumpiness.
Sample Input
3
2
3
1
Sample Output
7
Hint
2 3 1 : Initial order.
2 1 3 : After interchanging cows with grumpiness 3 and 1 (time=1+3=4).
1 2 3 : After interchanging cows with grumpiness 1 and 2 (time=2+1=3).

代码

#include<cstdio>
#include<vector>
#include<algorithm> 
#include<cstring>
using namespace std;
#define LL long long 

const int MAXN = 1e4+11;
const int MAXM = 1e5+11;
const int mod = 1e9+7;
const int inf = 0x3f3f3f3f;

int arr[MAXN],sum[MAXN],hash[MAXM]; bool vis[MAXN];
vector<int>ve[MAXN];int sz; //  存的循环 
int n;
void init(){
    memset(vis,0,sizeof(vis));
    memset(sum,0,sizeof(sum));
    memset(hash,0,sizeof(hash));
    for(int i=0;i<=n+11;i++) ve[i].clear();
}
int main(){
    int n;
    while(scanf("%d",&n)!=EOF){
        init();
        int minn=inf;
        for(int i=1;i<=n;i++) {
            scanf("%d",&arr[i]);
            minn=min(minn,arr[i]);
            hash[arr[i]]=i;
        } 
        sort(arr+1,arr+1+n);
        sz=0;
        for(int i=1;i<=n;i++){  // 遍历找循环节 
            if(!vis[i]) {
                ve[sz].push_back(arr[i]); vis[i]=true;
                int j=hash[arr[i]];
                while(j!=i){
                    //printf("j=%d\n",j);
                    ve[sz].push_back(arr[j]);
                    vis[j]=true;
                    j=hash[arr[j]];
                }
                sz++;
            }
        }
        for(int i=0;i<sz;i++){
            sort(ve[i].begin(),ve[i].end());
            for(int j=0;j<ve[i].size();j++) 
                sum[i]+=ve[i][j];
        }

        LL ans=0;
        for(int i=0;i<sz;i++){
            LL s1=sum[i]+ve[i][0]*(ve[i].size()-2);
            LL s2=sum[i]+minn+ve[i][0]+ve[i].size()*minn;
            ans+=min(s1,s2);
        }
        if(n==1)  puts("0");
        else printf("%lld\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值