【HDU - 6319】Ascending Rating 【单调队列】

Before the start of contest, there are n ICPC contestants waiting in a long queue. They are labeled by 1 to n from left to right. It can be easily found that the i-th contestant’s QodeForces rating is ai.
Little Q, the coach of Quailty Normal University, is bored to just watch them waiting in the queue. He starts to compare the rating of the contestants. He will pick a continous interval with length m, say [l,l+m1] [ l , l + m − 1 ] , and then inspect each contestant from left to right. Initially, he will write down two numbers maxrating=−1 and count=0. Everytime he meets a contestant k with strictly higher rating than maxrating, he will change maxrating to ak and count to count+1.
Little T is also a coach waiting for the contest. He knows Little Q is not good at counting, so he is wondering what are the correct final value of maxrating and count. Please write a program to figure out the answer.

Input
The first line of the input contains an integer T(1T2000) T ( 1 ≤ T ≤ 2000 ) denoting thenumber of test cases.
In each test case, there are7 integers n,m,k,p,q,r,MOD(1≤m,k≤n≤107,5≤p,q,r ,MOD ≤ 109) in the first line, denoting the number of contestants, the length of interval, and the parameters k,p,q,r,MOD.
In the next line, there are k integers a1,a2,...,ak(0ai109) a 1 , a 2 , . . . , a k ( 0 ≤ a i ≤ 109 ) , denoting the rating of the first k contestants.
To reduce the large input, we will use the following generator. The numbers p,q,r and MOD are given initially. The values ai(k<in) a i ( k < i ≤ n ) are then produced as follows :

ai=(p×ai1+q×i+r)modMOD a i = ( p × a i − 1 + q × i + r ) mod M O D

It is guaranteed that n7×107 ∑ n ≤ 7 × 107 and k2×106 ∑ k ≤ 2 × 106 .

Output
Since the output file may be very large, let’s denote maxratingi and counti as the result of interval [i,i+m1] [ i , i + m − 1 ] .
For each test case, you need to print a single line containing two integers A and B, where :

AB==i=1nm+1(maxratingii)i=1nm+1(countii) A = ∑ i = 1 n − m + 1 ( m a x r a t i n g i ⊕ i ) B = ∑ i = 1 n − m + 1 ( c o u n t i ⊕ i )

Note that “⊕” denotes binary XOR operation.

Sample Input

1
10 6 10 5 5 5 5
3 2 2 1 5 7 6 8 2 9

Sample Output

46 11

Source
2018 Multi-University Training Contest 3

分析:求固定区间大小的最大值和依次访问时的最大值的改变次数。
可以用经典的单调队列来解决区间最大值,同时当前的队列中元素的个数就是倒着访问最大值的改变次数,所以我们倒着遍历这个a序列就可以了。
代码
这个题目时间好紧张,按着标程走也都4000+ms

#include <bits/stdc++.h>
using namespace std;
#define fi first
#define se second
#define bug(x)  cout<<"@@  "<<x<<"\n"

typedef long long ll;
typedef unsigned long long ull;
typedef pair<int, int> pii;

const int N = (int) 1e7 + 11;
const int M = (int) 1e6 + 11;
const int INF = (int)0x3f3f3f3f;
const int MOD = (int)1e9 + 7;

#include <ext/rope>
using namespace __gnu_cxx;

int a[N + 1];
int que[N + 1], L, R; //单调队列,维护当前区间的最大值=que[L] 
int main(){
    #ifndef ONLINE_JUDGE
        freopen("in.txt", "r", stdin);
        freopen("out.txt", "w", stdout);
    #endif

    int _; scanf("%d", &_);
    while(_--){
        int n, m, k, p, q, r, mod;
        scanf("%d%d%d%d%d%d%d", &n, &m, &k, &p, &q, &r, &mod);
        for(int i = 1; i <= n; i++){
            if(i <= k) {
                scanf("%d" , &a[i]);
            }else {
                a[i] = (p * 1ll * a[i - 1] % mod + q * 1ll * i % mod + r) % mod;  
            }
        }
        //for(int i = 1; i <= n; i++) printf("%d ", a[i]); puts("");
        L = 1, R = 0;
        ll A = 0, B = 0;
        for(int i = n; i >= 1; i--){
            if(R < L){
                que[++R] = i; 
            } else {
                while(R >= L && a[que[R]] <= a[i]) R--;
                que[++R] = i;
            }

            if(i <= n - m + 1){
                while(L <= R && que[L] > i + m - 1) L++;
                A += i ^ a[que[L]];
                B += i ^ (R - L + 1);
            }
        }
        printf("%lld %lld\n", A, B);
    } 
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值