UVA - 1587 Box

题目来源:https://cn.vjudge.net/problem/UVA-1587

题目:

Ivan works at a factory that produces heavy machinery. He has a simple job — he knocks up woodenboxes of different sizes to pack machinery for delivery to the customers. Each box is a rectangularparallelepiped. Ivan uses six rectangular wooden pallets to make a box. Each pallet is used for one sideof the box.


Joe delivers pallets for Ivan. Joe is not very smart and often makes mistakes — he brings Ivanpallets that do not fit together to make a box. But Joe does not trust Ivan. It always takes a lot oftime to explain Joe that he has made a mistake.

Fortunately, Joe adores everything related to computers and sincerely believes that computers nevermake mistakes. Ivan has decided to use this for his own advantage. Ivan asks you to write a programthat given sizes of six rectangular pallets tells whether it is possible to make a box out of them.

Input

Input file contains several test cases. Each of them consists of six lines. Each line describes one palletand contains two integer numbers w and h (1 ≤ w, h ≤ 10 000) — width and height of the pallet inmillimeters respectively.

Output

For each test case, print one output line. Write a single word ‘POSSIBLE’ to the output file if it ispossible to make a box using six given pallets for its sides. Write a single word ‘IMPOSSIBLE’ if it is notpossible to do so.

Sample Input

1345 2584
2584 683
2584 1345
683 1345
683 1345
2584 683
1234 4567
1234 4567
4567 4321
4322 4567
4321 1234
4321 1234

Sample Output

POSSIBLE
IMPOSSIBLE


题意:给定6个面的长和宽,是否能够组成长方体

分析:

  1. 长方体只有长宽高三个数值(可能有相等的),所有出现4个及4个以上的都是错的。
  2. 每个数值相等的数目应该是4的倍数
  3. 一个面有相等的两条边,则与这条边相等的数目应该有8或者12
自己的测试数据:

1 1 1 1 1 1 1 1 2 2 2 2

1 3 3 2 2 1 3 1 1 2 2 3

1 2 1 1   1 2 1 1 1 2 1 2

代码:
#include <bits/stdc++.h>
using namespace std;
int main()
{
	set<int>s;
	map<int,int>m;
	int a[10],b[10],i;
	while(~scanf("%d %d",&a[0],&b[0]))
	{
		s.clear();
		m.clear();
		s.insert(a[0]);s.insert(b[0]);
		m[a[0]]++;m[b[0]]++;
		for(i=1;i<6;i++)
		{
			scanf("%d %d",&a[i],&b[i]);
			s.insert(a[i]);s.insert(b[i]);
			m[a[i]]++;m[b[i]]++;
		}
		if(s.size()>3)
		{
			puts("IMPOSSIBLE");
			continue;
		}
		else 
		{
			for(i=0;i<6;i++)
			{
				if(m[a[i]]%4!=0||m[b[i]]%4!=0)
					break;
				else if(a[i]==b[i]&&(m[a[i]]!=8&&m[b[i]]!=12))
					break;
			}
			if(i==6)puts("POSSIBLE");
			else puts("IMPOSSIBLE");
		}
	}
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值