Rita loves her Birthday parties. She is really happy when
blowing the candles at the Happy Birthday’s clap melody.
Every year since the age of four she adds her birthday candles
(one for every year of age) to a candle box. Her younger
daydreaming brother Theo started doing the same at the age
of three. Rita and Theo boxes look the same, and so do the
candles.
One day Rita decided to count how many candles she had
in her box:
− No, no, no! I’m younger than that!
She just realized Theo had thrown some of his birthday
candles in her box all these years. Can you help Rita fix the
number of candles in her candle box?
Given the difference between the ages of Rita and Theo,
the number of candles in Rita’s box, and the number of candles
in Theo’s box, find out how many candles Rita needs to
remove from her box such that it contains the right number
of candles.
Input
The input file contains several test cases, each of them as described below.
The first line of the input has one integer D, corresponding to the difference between the ages of
Rita and Theo.
The second line has one integer R, corresponding to the number of candles in Rita’s box.
The third line has one integer T, corresponding to the number of candles in Theo’s box.
Constraints
1 ≤ D ≤ 20 Difference between the ages of Rita and Theo
4 ≤ R < 1 000 Number of candles in Rita’s box
0 ≤ T < 1 000 Number of candles in Theo’s box
Output
For each test case, write to the output an integer, on a line by itself, representing the number of candles
Rita must remove from her box such that it contains the right number of candles.
Sample Input
2
26
8
Sample Output
4
题目大意:
姐姐从四岁开始,包括第四岁,每次生日,姐姐会给自己的盒子里放与年龄相等的蜡烛数目;
弟弟是从三岁开始,每次生日,也给自己的盒子里放与年龄相等的蜡烛数目;
其中 ,弟弟会随机往姐姐的盒子里扔蜡烛;
输入:
第一行 姐姐和弟弟相差的年龄;
第二行:姐姐的盒子里的蜡烛数;
第三行:弟弟的~;
输出: 弟弟往姐姐的盒子扔了多少根蜡烛;
#include<bits/stdc++.h>
using namespace std;
int main()
{
int d;
int x, y;
while(~scanf("%d", &d))
{
scanf("%d", &x);
scanf("%d", &y);
int sum = x + y;
int numm = 0;
int numm1;
for(int i=4;i<1000;i++)
{
numm += i;
numm1 = 0;
for(int j=0;j<=i-d;j++)
{
if(j>=3)
{
numm1 = numm1 + j;
}
else
{
continue;
}
}
if(numm1 + numm == sum)
{
break;
}
}
printf("%d\n", x - numm);
//printf("%d\n", numm1 - y);
}
return 0;
}