F - Candle Box UVA - 13161

这道题是关于Rita和Theo兄弟俩的生日蜡烛。Rita每年都会把自己的年龄数作为蜡烛放入盒中,而Theo有时会把他的蜡烛混入Rita的盒子里。给定他们年龄的差值、Rita的蜡烛数和Theo的蜡烛数,需要计算Rita需要从盒子里移除多少根蜡烛以使数量正确。
摘要由CSDN通过智能技术生成

Rita loves her Birthday parties. She is really happy when
blowing the candles at the Happy Birthday’s clap melody.
Every year since the age of four she adds her birthday candles
(one for every year of age) to a candle box. Her younger
daydreaming brother Theo started doing the same at the age
of three. Rita and Theo boxes look the same, and so do the
candles.
One day Rita decided to count how many candles she had
in her box:
− No, no, no! I’m younger than that!
She just realized Theo had thrown some of his birthday
candles in her box all these years. Can you help Rita fix the
number of candles in her candle box?
Given the difference between the ages of Rita and Theo,
the number of candles in Rita’s box, and the number of candles
in Theo’s box, find out how many candles Rita needs to
remove from her box such that it contains the right number
of candles.

Input

The input file contains several test cases, each of them as described below.
The first line of the input has one integer D, corresponding to the difference between the ages of
Rita and Theo.
The second line has one integer R, corresponding to the number of candles in Rita’s box.
The third line has one integer T, corresponding to the number of candles in Theo’s box.
Constraints
1 ≤ D ≤ 20 Difference between the ages of Rita and Theo
4 ≤ R < 1 000 Number of candles in Rita’s box
0 ≤ T < 1 000 Number of candles in Theo’s box

Output

For each test case, write to the output an integer, on a line by itself, representing the number of candles
Rita must remove from her box such that it contains the right number of candles.

Sample Input

2
26
8

Sample Output

4

题目大意:

姐姐从四岁开始,包括第四岁,每次生日,姐姐会给自己的盒子里放与年龄相等的蜡烛数目;
弟弟是从三岁开始,每次生日,也给自己的盒子里放与年龄相等的蜡烛数目;
其中 ,弟弟会随机往姐姐的盒子里扔蜡烛;
输入:
第一行 姐姐和弟弟相差的年龄;
第二行:姐姐的盒子里的蜡烛数;
第三行:弟弟的~;
输出: 弟弟往姐姐的盒子扔了多少根蜡烛;

#include<bits/stdc++.h>

using namespace std;
int main()
{
    int d;
    int x, y;
    while(~scanf("%d", &d))
    {
    scanf("%d", &x);
    scanf("%d", &y);
    int sum = x + y;
    int numm = 0;
    int numm1;
    for(int i=4;i<1000;i++)
    {
        numm += i;
        numm1 = 0;
       for(int j=0;j<=i-d;j++)
       {
          if(j>=3)
          {
          numm1 = numm1 + j;
          }
          else
          {
            continue;
          }
       }
       if(numm1 + numm == sum)
       {
          break;
       }
    }
    printf("%d\n", x - numm);
    //printf("%d\n", numm1 - y);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值