HDU 2639 Bone Collector II DP 第K优解

 

Bone Collector II

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5142    Accepted Submission(s): 2709


Problem Description
The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link:

Here is the link: http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.
 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the K-th maximum of the total value (this number will be less than 2 31).
 

Sample Input
      
      
3 5 10 2 1 2 3 4 5 5 4 3 2 1 5 10 12 1 2 3 4 5 5 4 3 2 1 5 10 16 1 2 3 4 5 5 4 3 2 1
 

Sample Output
      
      
12 2 0
其实在求DP的最优解的过程中,所有可能的解都已经计算过一遍,只不过保存的是只有最优解,开两个数组模拟一下这个过程记录中间值最后就可以得到除最优解之外的解
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<stdlib.h>
#include<iostream>
int dp[5050][55],vol[1005],val[1005],a[55],b[55]; // a和b用来保存中间未整合的结果 
using namespace std;
int main()
{
	int terms;
	scanf("%d",&terms);
	while(terms--)
	{
		memset(dp,0,sizeof(dp));
		int n,m,k;
		scanf("%d%d%d",&n,&m,&k);
		for(int i=1;i<=n;i++)
			scanf("%d",&val[i]);
		for(int i=1;i<=n;i++)
			scanf("%d",&vol[i]);
		for(int i=1;i<=n;i++)
		{
			for(int j=m;j>=vol[i];j--)
			{
				for(int k1=1;k1<=k;k1++)
				{
					a[k1]=dp[j-vol[i]][k1]+val[i];//放物品i 
					b[k1]=dp[j][k1];//不放物品i 
				}
				int x=1,y=1,k2=1;
				a[k+1]=-1;
				b[k+1]=-1;
				while((a[x]!=-1 || b[y]!=-1) && k2<=k)//注意前面的 ||,因为可能两个不同时到底 
				{
					if(a[x] > b[y])
						dp[j][k2]=a[x++];
					else
						dp[j][k2]=b[y++];
					if(dp[j][k2]!=dp[j][k2-1])
						k2++;
				}
			}
		}
		printf("%d\n",dp[m][k]);
	}
	return 0;
}

说实话过程不是太理解,先水过再说吧
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值