CPE练习(一):11764 Cricket Field——JAVA

CPE题目

题目链接:
https://uva.onlinejudge.org/external/117/p11764.pdf
题目文字:
Mario is in the final castle. He now needs to
jump over few walls and then enter the Koopa’s
Chamber where he has to defeat the monster in
order to save the princess. For this problem,
we are only concerned with the “jumping over
the wall” part. You will be given the heights
of N walls from left to right. Mario is currently
standing on the first wall. He has to jump to the
adjacent walls one after another until he reaches
the last one. That means, he will make (N − 1)
jumps. A high jump is one where Mario has to
jump to a taller wall, and similarly, a low jump is one where Mario has to jump to a shorter wall. Can you find out the total number of high jumps and low jumps Mario has to make?

  • Input
    The first line of input is an integer T (T < 30) that indicates the number of test cases. Each case starts with an integer N (0 < N < 50) that determines the number of walls. The next line gives the height of the N walls from left to right. Each height is a positive integer not exceeding 10.
  • Output
    For each case, output the case number followed by 2 integers, total high jumps and total low jumps, respectively. Look at the sample for exact format.
  • Sample Input
    3
    8 14223534 1
    9
    5
    12345
  • Sample Output
    Case 1: 4 2
    Case 2: 0 0
    Case 3: 4 0

代码如下:

import java.util.Scanner;

public class lyx {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner scanner=new Scanner(System.in);
		int number=scanner.nextInt();
		for(int num=1;num<=number;num++)
		{
		int count=scanner.nextInt();//每次输入数字
		int [] data=new int[50];//创建data数组 
			 for(int i=0;i<count;i++)	
			 {	 data[i]=scanner.nextInt();	 }
			 int max=0 , min=0;
			 for(int i=0;i<count-1;i++)	
			 {	
				 if((data[i+1]-data[i])>0)
				 {max++;}
				 else if((data[i+1]-data[i])<0)
				 {min++;}
			 }
			 System.out.println("Case "+num+": "+max+" "+min);

		}

	}

}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Laura_Wangzx

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值