Ancient Go UESTC - 1221 (dfs)

Ancient Go UESTC - 1221 (dfs)

http://acm.uestc.edu.cn/#/problem/show/1221>sd
Yu Zhou likes to play Go with Su Lu. From the historical research, we found that there are much difference on the rules between ancient go and modern go.
Here is the rules for ancient go they were playing:
The game is played on a
8×8
8×8
cell board, the chess can be put on the intersection of the board lines, so there are
9×9
9×9
different positions to put the chess.
Yu Zhou always takes the black and Su Lu the white. They put the chess onto the game board alternately.
The chess of the same color makes connected components(connected by the board lines), for each of the components, if it’s not connected with any of the empty cells,
this component dies and will be removed from the game board.
When one of the player makes his move, check the opponent’s components first. After removing the dead opponent’s components, check with the player’s components and remove
the dead components.
One day, Yu Zhou was playing ancient go with Su Lu at home. It’s Yu Zhou’s move now. But they had to go for an emergency military action. Little Qiao looked at the game board and
would like to know whether Yu Zhou has a move to kill at least one of Su Lu’s chess

Input
The first line of the input gives the number of testcases,TT(1≤T≤100
1≤T≤100). TTtest cases follow. Test cases are separated by an empty line. Each test case consist of 9*9lines represent the game board. Each line consists of 9*9
characters. Each character represents a cell on the game board. . represents an empty cell. x represents a
cell with black chess which owned by Yu Zhou. o represents a cell with white chess which owned by Su Lu.

Output

For each test case, output one line containing Case #x: y, where xx is the test case number (starting from 11) and yy
is Can kill in one move!!! if Yu Zhou has a move to kill at least one of Su Lu’s components. Can not kill in one move!!! otherwise.

Sample Input

2

…….xo
………
………
..x……
.xox….x
.o.o…xo
..o……
…..xxxo
….xooo.

……ox.
…….o.
…o…..
..o.o….
…o…..
………
…….o.
…x…..
……..o

Sample Output

Case #1: Can kill in one move!!!
Case #2: Can not kill in one move!!!

#include<stdio.h>
#include<string.h>
#define  max  4
int  b[10][10]={0};
char xx[10][10]={0};
int flag=0;
int ans=0;
int vv[10][10];
int w[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
void bfs(int x,int y)
{

    for(int i=0;i<4;i++)
    {
        int x1=x+w[i][0];
        int y1=y+w[i][1];
        if (x1>=0&&y1>=0&&x1<9&&y1<9&&xx[x1][y1]=='.'&&!vv[x1][y1])
        {
            vv[x1][y1]=1;
            ans++;

        }

    }

    for(int i=0;i<4;i++)
    {

        int x1=x+w[i][0];
        int y1=y+w[i][1];
            if (x1>=0&&y1>=0&&x1<9&&y1<9&&xx[x1][y1]=='o'&&!b[x1][y1])
            {
                b[x1][y1]=1;
                bfs(x1,y1);
            }


    }






}
int main()
{

    int t;
    scanf("%d",&t);
    int tt=0;
    getchar();
    while(t--)
    {
        tt++;
        flag=0;
        for(int i=0;i<9;i++)
        {
            scanf("%s",&xx[i]);

        }
        memset(b,0,sizeof(b));
        for(int i=0;i<9;i++)
        {

            for(int j=0;j<9;j++)
            {

                if(xx[i][j]=='o'&&(!b[i][j]))
                {   memset(vv,0,sizeof(vv));
                    ans=0;
                    b[i][j]=1;
                    bfs(i,j);
                    if(ans==1)
                    {
                        flag=1;
                        break;

                    }


                }

            }


            if(flag)
            break;


        }
            if(flag)  
            printf("Case #%d: Can kill in one move!!!\n",tt);  
        else  
            printf("Case #%d: Can not kill in one move!!!\n",tt);  


    }



    return 0;

}

“感觉还是对DFS太生疏了

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值