POJ 3268

Silver Cow Party
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 23404 Accepted: 10678

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively:  NM, and  X 
Lines 2.. M+1: Line  i+1 describes road  i with three space-separated integers:  AiBi, and  Ti. The described road runs from farm  Ai to farm  Bi, requiring  Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

题意:

有向图,问所有点到某一点X来回的最短距离中最长的距离是多少。(有点拗口)

题目分析:

一开始想的是先从终点X跑一遍Dijkstra或者SPFA,Floyd指定超时,数量级达到了10^3。然后再从各点跑一遍Dijkstra或者SPFA,两次加和求最大值即可,但是超时了。后来灵光一现,想到可以倒着跑一遍,这样只需跑两遍Dijkstra或者SPFA即可,

但在存距离的时候要存在两个数组中了。

AC代码:

#include <iostream>
#include <cstdio>
#include <fstream>
#include <algorithm>
#include <cmath>
#include <deque>
#include <vector>
#include <queue>
#include <string>
#include <cstring>
#include <map>
#include <stack>
#include <set>
#include <climits>
using namespace std;
int N, M, X;
const int MAXN=1e3+10;
const int maxx=INT_MAX;
int data1[MAXN][MAXN], data2[MAXN][MAXN], Distance[MAXN], z[MAXN];
bool pin[MAXN], collect1[MAXN][MAXN], collect2[MAXN][MAXN];
void start()
{
    for(int i=1; i<=N; i++)
    {
        for(int j=1; j<=N; j++)
        {
            if(i==j)
            {
                data1[i][j]=0;
                data2[i][j]=0;
            }
            else
            {
                data1[i][j]=maxx;
                data2[i][j]=maxx;
            }
        }
    }
    memset(collect1,false,sizeof(collect1));
    memset(collect2,false,sizeof(collect2));
    memset(pin,false,sizeof(pin));
    memset(z,0,sizeof(z));
}
bool cmp(int a, int b)
{
    return a>b;
}
int zhao()
{
    int a=-1, b=maxx;
    for(int i=1; i<=N; i++)
    {
        if(!pin[i]&&Distance[i]<b)
        {
            a=i;
            b=Distance[i];
        }
    }
    return a;
}
void Dijkstra(int x, bool collect[][MAXN], int data[][MAXN])
{
    Distance[x]=0;
    pin[x]=true;
    while(1)
    {
        int m=zhao();
        if(m==-1)
            break;
        pin[m]=true;
        for(int i=1; i<=N; i++)
        {
            if(collect[m][i]&&!pin[i])
                Distance[i]=min(Distance[i],Distance[m]+data[m][i]);
        }
    }
}
void SPFA(int x, bool collect[][MAXN], int data[][MAXN])
{
    queue<int>Q;
    Distance[x]=0;
    Q.push(x);
    pin[x]=true;
    while(!Q.empty())
    {
        int m=Q.front();
        Q.pop();
        pin[m]=false;
        for(int i=1; i<=N; i++)
        {
            if(collect[m][i]&&Distance[i]>Distance[m]+data[m][i])
            {
                Distance[i]=Distance[m]+data[m][i];
                if(!pin[i])
                {
                    Q.push(i);
                    pin[i]=true;
                }
            }
        }
    }
}
int main()
{
    while(cin>>N>>M>>X)
    {
        start();
        int a, b, c;
        while(M--)
        {
            cin>>a>>b>>c;
            if(data1[a][b]>c)
            {
                collect1[a][b]=true;///分别存在两个不同数组中
                collect2[b][a]=true;
                data1[a][b]=c;
                data2[b][a]=c;
            }
        }
        for(int i=1; i<=N; i++)
            Distance[i]=data1[X][i];
        Dijkstra(X,collect1,data1);///Dijkstra算法的Distance数组需要提前赋值,否则在找Distance最小时出错,而SPFA算法则不用,直接赋值为maxx即可


        for(int i=1; i<=N; i++)
            z[i]+=Distance[i];
        for(int j=1; j<=N; j++)
            Distance[j]=data2[X][j];
        memset(pin,false,sizeof(pin));
        Dijkstra(X,collect2,data2);
        for(int i=1; i<=N; i++)
            z[i]+=Distance[i];
        sort(z+1,z+N+1,cmp);
        cout<<z[1]<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值