POJ 3895 Cycles of Lanes(dfs+模拟)

97 篇文章 0 订阅
21 篇文章 0 订阅

Each of the M lanes of the Park of Polytechnic University of Bucharest connects two of the N crossroads of the park (labeled from 1 to N). There is no pair of crossroads connected by more than one lane and it is possible to pass from each crossroad to each other crossroad by a path composed of one or more lanes. A cycle of lanes is simple when passes through each of its crossroads exactly once. 
The administration of the University would like to put on the lanes pictures of the winners of Regional Collegiate Programming Contest in such way that the pictures of winners from the same university to be on the lanes of a same simple cycle. That is why the administration would like to assign the longest simple cycles of lanes to most successful universities. The problem is to find the longest cycles? Fortunately, it happens that each lane of the park is participating in no more than one simple cycle (see the Figure). 

Input
On the first line of the input file the number T of the test cases will be given. Each test case starts with a line with the positive integers N and M, separated by interval (4 <= N <= 4444). Each of the next M lines of the test case contains the labels of one of the pairs of crossroads connected by a lane.
Output
For each of the test cases, on a single line of the output, print the length of a maximal simple cycle.
Sample Input
1 
7 8 
3 4 
1 4 
1 3 
7 1 
2 7 
7 5 
5 6 
6 2
Sample Output
4

题解:

这题比赛中做出来的第一题,想法就是一次性的dfs,这个要意会。。在代码中看看吧

代码:

#include<algorithm>
#include<iostream>
#include<cstring>
#include<stdio.h>
#include<math.h>
#include<string>
#include<stdio.h>
#include<queue>
#include<stack>
#include<map>
#include<deque>
using namespace std;
struct edge
{
    int f,t;
};
int a[4500][105];//保存每个节点对应的边的编号
edge b[4500];//保存每个边
int num[4500];//保存每个点连接边的数目
int vis[4500];//保存每个边是否被访问过
int dis[4500];//保存每个节点的最后位置
int maxx,n,m;
void dfs(int index,int step)
{
    if(dis[index])
    {
        int t=step-dis[index];
        if(maxx<t)
        {
            maxx=t;
        }
        step=dis[index];//回到了原处要回溯一下位置信息
    }
    else
        dis[index]=step;//没有经过就记录一下最初位置
    for(int i=0;i<num[index];i++)
    {
        if(!vis[a[index][i]])//边没遍历过就走一遍
        {
            vis[a[index][i]]=1;
            int d=((index==b[a[index][i]].f)?b[a[index][i]].t:b[a[index][i]].f);//d得出来的是该节点通往何处
            dfs(d,step+1);
        }
    }
}
int main()
{
    int i,j,test,x,y;
    scanf("%d",&test);
    while(test--)
    {
        scanf("%d%d",&n,&m);
        memset(num,0,sizeof(num));
        memset(dis,0,sizeof(dis));
        for(i=0;i<m;i++)
        {
            scanf("%d%d",&x,&y);
            b[i].f=x;//储存边的信息
            b[i].t=y;
            vis[i]=0;//初始化
            a[x][num[x]]=i;
            num[x]++;
            a[y][num[y]]=i;
            num[y]++;
        }
        maxx=0;
        for(i=1;i<=n;i++)//一开始wa就是没有这个,因为可能有些点互相不连通
        {
            if(!dis[i])
                dfs(1,1);
        }
        printf("%d\n",maxx);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值