Cycles of Lanes

Each of the M lanes of the Park of Polytechnic University of Bucharest connects two of the N crossroads of the park (labeled from 1 to N). There is no pair of crossroads connected by more than one lane and it is possible to pass from each crossroad to each other crossroad by a path composed of one or more lanes. A cycle of lanes is simple when passes through each of its crossroads exactly once. 
The administration of the University would like to put on the lanes pictures of the winners of Regional Collegiate Programming Contest in such way that the pictures of winners from the same university to be on the lanes of a same simple cycle. That is why the administration would like to assign the longest simple cycles of lanes to most successful universities. The problem is to find the longest cycles? Fortunately, it happens that each lane of the park is participating in no more than one simple cycle (see the Figure). 

Input

On the first line of the input file the number T of the test cases will be given. Each test case starts with a line with the positive integers N and M, separated by interval (4 <= N <= 4444). Each of the next M lines of the test case contains the labels of one of the pairs of crossroads connected by a lane.

Output

For each of the test cases, on a single line of the output, print the length of a maximal simple cycle.

Sample Input

1 
7 8 
3 4 
1 4 
1 3 
7 1 
2 7 
7 5 
5 6 
6 2

Sample Output

4
#include<iostream>
#include<algorithm>
#include<cstring>
#include<vector>
using namespace std;
vector<vector<int> > e;
int vis[5000];
int ans;
void dfs(int x,int cnt){
	vis[x] = cnt;
	for(int i = 0;i < e[x].size();i++){
		if(!vis[e[x][i]]) {
			dfs(e[x][i],cnt+1);
		}
		else{
			ans = max(ans,cnt - vis[e[x][i]] + 1);
		} 
	}
}
int main()
{
	int t;
	cin>>t;
	while(t --){
		memset(vis,0,sizeof(vis));
		ans = 0;
		int n,m,x,y;
		cin>>n>>m;
		vector<vector<int> > e1(n+1,vector<int>());
		e = e1;
		for(int i = 0;i < m;i ++){
			cin>>x>>y;
			e[x].push_back(y),e[y].push_back(x);
		}
		for(int i = 1;i <= n;i ++){
			if(!vis[i]) dfs(i,1);
		}
		if(ans >= 3) cout<<ans<<endl;
		else cout<<"0"<<endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值