POJ 3626 Mud Puddles(bfs)

18 篇文章 0 订阅

Farmer John is leaving his house promptly at 6 AM for his daily milking of Bessie. However, the previous evening saw a heavy rain, and the fields are quite muddy. FJ starts at the point (0, 0) in the coordinate plane and heads toward Bessie who is located at (XY) (-500 ≤ X ≤ 500; -500 ≤ Y ≤ 500). He can see all N (1 ≤ N ≤ 10,000) puddles of mud, located at points (AiBi) (-500 ≤ Ai ≤ 500; -500 ≤ Bi ≤ 500) on the field. Each puddle occupies only the point it is on.

Having just bought new boots, Farmer John absolutely does not want to dirty them by stepping in a puddle, but he also wants to get to Bessie as quickly as possible. He's already late because he had to count all the puddles. If Farmer John can only travel parallel to the axes and turn at points with integer coordinates, what is the shortest distance he must travel to reach Bessie and keep his boots clean? There will always be a path without mud that Farmer John can take to reach Bessie.

Input

* Line 1: Three space-separate integers: XY, and N.
* Lines 2..N+1: Line i+1 contains two space-separated integers: Ai and Bi

Output

* Line 1: The minimum distance that Farmer John has to travel to reach Bessie without stepping in mud.

Sample Input
1 2 7
0 2
-1 3
3 1
1 1
4 2
-1 1
2 2
Sample Output
11

题解:

一题很简单的bfs,就是由于横纵坐标有负数,所有坐标加上500就是了

代码:

#include<algorithm>
#include<iostream>
#include<cstring>
#include<stdio.h>
#include<math.h>
#include<string>
#include<stdio.h>
#include<queue>
#include<stack>
#include<map>
#include<deque>
using namespace std;
struct node
{
    int x,y;
    int step;
};
int p[1005][1005];//存图
int dirx[4]={0,0,-1,1};//方向数组
int diry[4]={1,-1,0,0};
queue<node>q;
int main()
{
    int etx,ety,i,j,k,n,m,x,y,s,xx,yy;
    node now,next;
    memset(p,0,sizeof(p));
    scanf("%d%d%d",&etx,&ety,&n);
    etx+=500;
    ety+=500;//由于有负数,加上500
    for(i=0;i<n;i++)
    {
        scanf("%d%d",&x,&y);
        x+=500;
        y+=500;
        p[x][y]=1;
    }
    now.x=500;
    now.y=500;
    now.step=0;
    q.push(now);
    p[500][500]=1;
    s=0;
    while(!q.empty())//日常bfs
    {
        now=q.front();
        q.pop();
        for(i=0;i<4;i++)
        {
            xx=now.x+dirx[i];
            yy=now.y+diry[i];
            if(xx>=0&&yy>=0&&xx<=1000&&yy<=1000&&!p[xx][yy])
            {
                next.step=now.step+1;
                next.x=xx;
                next.y=yy;
                p[xx][yy]=1;
                if(p[etx][ety])
                {
                    s=next.step;
                    goto loop;
                }
                q.push(next);
            }
        }
    }
    loop:
        printf("%d\n",s);
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值