HDU 1082 COURSES (二分图匹配之匈牙利算法)

55 篇文章 0 订阅
16 篇文章 0 订阅

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions: 

  • every student in the committee represents a different course (a student can represent a course if he/she visits that course) 
  • each course has a representative in the committee 
Input
Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format: 

P N 
Count1 Student  1 1 Student  1 2 ... Student  1 Count1 
Count2 Student  2 1 Student  2 2 ... Student  2 Count2 
... 
CountP Student  P 1 Student  P 2 ... Student  P CountP 

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses �from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N. 
There are no blank lines between consecutive sets of data. Input data are correct. 
Output
The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.
Sample Input
2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1
Sample Output
YES
NO

题解:

题意:

有m门课,n个人,然后输入时第i门课有几个人喜欢,分别是谁。。

ps:之前没做过这类题,比赛的时候看到所有队都过了这题就慌了,然后就百度博客学习了下。。。这还是个模板题

代码:

#include<algorithm>
#include<iostream>
#include<cstring>
#include<stdio.h>
#include<math.h>
#include<string>
#include<stdio.h>
#include<queue>
#include<stack>
#include<map>
#include<deque>
#define M (t[k].l+t[k].r)/2
#define lson k*2
#define rson k*2+1
using namespace std;
int vis[305];//遍历数组
int p[105][305];//存第i门课第j个人是否喜欢
int g[305];//存第i个人是第几门课的课代表
int n,m;
int find(int u)//为第u门课找课代表
{
    int i,j;
    for(i=1;i<=n;i++)
    {
        if(p[u][i]&&!vis[i])//如果第i个人喜欢这门课且没被遍历过
        {
            vis[i]=1;
            if(!g[i]||find(g[i]))//如果第i个人没被分配课代表或者原来分配的课代表可以找一个人替换掉
            {
                g[i]=u;
                return 1;//表示可以找到
            }
        }
    }
    return 0;//表示不能分配
}
int main()
{
    int i,j,k,test,x,y;
    scanf("%d",&test);
    while(test--)
    {
        scanf("%d%d",&m,&n);
        memset(p,0,sizeof(p));
        memset(g,0,sizeof(g));
        for(i=1;i<=m;i++)
        {
            scanf("%d",&x);
            for(j=0;j<x;j++)
            {
                scanf("%d",&y);
                p[i][y]=1;
            }
        }
        if(n<m)//人数小于课数
        {
            printf("NO\n");
            continue;
        }
        for(i=1;i<=m;i++)
        {
            memset(vis,0,sizeof(vis));//每次都要初始化遍历数组
            if(!find(i))
                break;
        }
        if(i==m+1)//说明每一个人都找到了课代表
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值