HDU 3294 Girls' research(Manacher算法求回文串左右端点)

93 篇文章 1 订阅
3 篇文章 0 订阅

One day, sailormoon girls are so delighted that they intend to research about palindromic strings. Operation contains two steps: 
First step: girls will write a long string (only contains lower case) on the paper. For example, "abcde", but 'a' inside is not the real 'a', that means if we define the 'b' is the real 'a', then we can infer that 'c' is the real 'b', 'd' is the real 'c' ……, 'a' is the real 'z'. According to this, string "abcde" changes to "bcdef".
Second step: girls will find out the longest palindromic string in the given string, the length of palindromic string must be equal or more than 2.
Input
Input contains multiple cases. 
Each case contains two parts, a character and a string, they are separated by one space, the character representing the real 'a' is and the length of the string will not exceed 200000.All input must be lowercase. 
If the length of string is len, it is marked from 0 to len-1.
Output
Please execute the operation following the two steps. 
If you find one, output the start position and end position of palindromic string in a line, next line output the real palindromic string, or output "No solution!". 
If there are several answers available, please choose the string which first appears.
Sample Input
b babd
a abcd
Sample Output
0 2
aza
No solution!

题解:

题意:

先给你一个字符,代表该字符表示‘a’,然后其他25个字符根据该字符来推算,然后给你一个串,让你求出最长回文串的左右端点,如果相等长输出找到的第一个串,并输出根据要求改变后的回文串

思路:

manacher里面稍加修改就行了,就是他一开始输入的字符处理起来有点麻烦。。推算一下就好了

代码:

#include<iostream>
#include<cstring>
#include<stdio.h>
#include<math.h>
#include<string>
#include<stdio.h>
#include<queue>
#include<stack>
#include<map>
#include<vector>
#include<deque>
#include<algorithm>
using namespace std;
#define lson k*2
#define rson k*2+1
#define M (t[k].l+t[k].r)/2
#define INF 100861111
#define ll long long
#define eps 1e-15
int p[400005];
int v[30];
char str[400005];
int l,r;
int manacher(char s[])//模板稍加修改
{
    int i;
    for(i=1;s[i];i++)
        str[i*2]=s[i],str[i*2+1]='#';
    str[0]='?',str[1]='#',str[i*2]='\0';
    int res=0, k=0,maxk=0;
    for(int i = 2; str[i]; i++)
    {
        p[i]=i<maxk?min(maxk-i,p[2*k-i]):1;
        while(str[i-p[i]]==str[i+p[i]])
            p[i]++;
        if(p[i]+i>maxk)
        {
            k=i,maxk=i+p[i];
        }
        if(res<p[i])
        {
            l=(i-p[i])/2;//这个地方修改了求左右端点
            r=(i+p[i])/2-2;
            res=p[i];
        }
    }
    return res-1;
}
int main()
{
    int test,i,j,t;
    char s[200005],c[10];
    while(scanf("%s%s",&c,s+1)!=EOF)
    {
        for(i=c[0]-'a',j=0;i<26;i++,j++)//也就是推算下其他字符的值
            v[i]=j;
        for(i=c[0]-'a'-1,j=-1;i>=0;i--,j--)
            v[i]=j;
        t=manacher(s);
        if(t<2)
        {
            printf("No solution!\n");
        }
        else
        {
            printf("%d %d\n",l,r);
            l++,r++;

            for(i=l;i<=r;i++)
            {
                if(v[s[i]-'a']>=0)
                    printf("%c",v[s[i]-'a']+'a');
                else
                    printf("%c",26+v[s[i]-'a']+'a');
            }
            printf("\n");
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值