2017 ACM-ICPC 亚洲区(乌鲁木齐赛区)网络赛 A. Banana(连通性水题)

55 篇文章 0 订阅

Bananas are the favoured food of monkeys.

In the forest, there is a Banana Company that provides bananas from different places.

The company has two lists.

The first list records the types of bananas preferred by different monkeys, and the second one records the types of bananas from different places.

Now, the supplier wants to know, whether a monkey can accept at least one type of bananas from a place.

Remenber that, there could be more than one types of bananas from a place, and there also could be more than one types of bananas of a monkey’s preference.

Input Format

The first line contains an integer TT, indicating that there are TT test cases.

For each test case, the first line contains two integers NN and MM, representing the length of the first and the second lists respectively.

In the each line of following NN lines, two positive integers i, ji,j indicate that the ii-th monkey favours the jj-th type of banana.

In the each line of following MM lines, two positive integers j, kj,k indicate that the jj-th type of banana could be find in the kk-th place.

All integers of the input are less than or equal to 5050.

Output Format

For each test case, output all the pairs x, yx,y that the xx-the monkey can accept at least one type of bananas from the yy-th place.

These pairs should be outputted as ascending order. That is say that a pair of x, yx,y which owns a smaller xx should be output first.

If two pairs own the same xx, output the one who has a smaller yy first.

And there should be an empty line after each test case.

样例输入


6 4 
1 1 
1 2 
2 1 
2 3 
3 3 
4 1 
1 1 
1 3 
2 2 
3 3 
样例输出

1 1 
1 2 
1 3 
2 1 
2 3 
3 3 
4 1 
4 3


题解:

上次网赛只a了一题。。这次抱着只a 2,3题的心态去做,这次居然a出了五题hhhhh,不过还是膜拜学长们。。。帮我买学校搞到排名17orz

思路:

类似于弗洛伊德的思想,比较水,数据也很小

代码:

#include<iostream>
#include<cstring>
#include<stdio.h>
#include<math.h>
#include<string>
#include<stdio.h>
#include<queue>
#include<stack>
#include<map>
#include<vector>
#include<deque>
#include<algorithm>
using namespace std;
#define INF 100861111
#define eps 1e-7
#define lson k*2
#define rson k*2+1
#define ll long long
int p1[55][55];
int p2[55][55];
int p3[55][55];
int main()
{
    int i,j,k,n,m,x,y,test;
    scanf("%d",&test);
    while(test--)
    {

    scanf("%d%d",&n,&m);
    memset(p1,0,sizeof(p1));
    memset(p2,0,sizeof(p2));
    memset(p3,0,sizeof(p3));
    for(i=0;i<n;i++)
    {
        scanf("%d%d",&x,&y);
        p1[x][y]=1;
    }
    for(i=0;i<m;i++)
    {
        scanf("%d%d",&x,&y);
        p2[x][y]=1;
    }
    for(i=0;i<=50;i++)
    {
        for(j=0;j<=50;j++)
        {
            for(k=0;k<=50;k++)
            {
                if(p1[i][k]&&p2[k][j])
                    p3[i][j]=1;
            }
        }
    }
    for(i=0;i<=50;i++)
    {
        for(j=0;j<=50;j++)
        {
            if(p3[i][j])
            {
                printf("%d %d\n",i,j);
            }
        }
    }
    printf("\n");

    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值