hdu1520简单树形dp

Anniversary party

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15000    Accepted Submission(s): 5828


Problem Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.
 

Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0
 

Output
Output should contain the maximal sum of guests' ratings.
 

Sample Input
 
 
7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0
 

Sample Output
 
 
5
 


这道题是父亲节点选了,子节点就不可以选,子节点选了,父亲节点就不可以选,因此每个点都要保存两种状态

1代表选,0代表不选

自下而上的递归

父亲节点选了后就不可以再选子节点,因此有

dp[fa][1]=dp[fa][1]+dp[son][0];

父亲节点不选则子节点可选可不选,因此有

dp[fa][0]=dp[fa][0]+max(dp[son][0],dp[son][1])

AC代码:

#include<iostream>
#include<vector>
#include<stdio.h>
#include<string.h>
#define maxn 6005
using namespace std;
int n;
int l,k;
vector<int>vec[maxn];
int degree[maxn];
int dp[maxn][2];//1代表选,0代表不选
int rating[maxn];
void dfs(int x)
{
    dp[x][1]=rating[x];
    for(int i=0; i<vec[x].size(); i++)
    {
        int temp=vec[x][i];
        dfs(temp);
        dp[x][1]=dp[x][1]+dp[temp][0];
        dp[x][0]=dp[x][0]+max(dp[temp][0],dp[temp][1]);
    }
    return ;
}
int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=0; i<=n; i++)
            vec[i].clear();
        memset(dp,0,sizeof(dp));
        memset(degree,0,sizeof(degree));
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&rating[i]);
        }
        while(~scanf("%d%d",&l,&k))
        {
            if(l==0&&k==0)
                break;
            vec[k].push_back(l);
            degree[l]++;
        }
        int root;
        for(int i=1; i<=n; i++)
        {
            if(degree[i]==0)
            {
                root=i;
                break;
            }
        }
        dfs(root);
        printf("%d\n",max(dp[root][0],dp[root][1]));
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值